summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..292665c322fb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = libbtbb
+ pkgdesc = Bluetooth baseband decoding library
+ pkgver = 2015.10.R1
+ pkgrel = 1
+ url = https://github.com/greatscottgadgets/libbtbb
+ arch = x86_64
+ arch = i686
+ license = GPL2
+ makedepends = cmake
+ depends = python
+ source = https://github.com/greatscottgadgets/libbtbb/archive/2015-10-R1.tar.gz
+ md5sums = 2315216adf16a0cee06e237c62122698
+
+pkgname = libbtbb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9c48a8b0f18f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+pkgname=libbtbb
+pkgver=2015.10.R1
+pkgrel=1
+pkgdesc='Bluetooth baseband decoding library'
+url='https://github.com/greatscottgadgets/libbtbb'
+arch=('x86_64' 'i686')
+license=('GPL2')
+makedepends=(cmake)
+depends=('python')
+source=("https://github.com/greatscottgadgets/libbtbb/archive/2015-10-R1.tar.gz")
+md5sums=('2315216adf16a0cee06e237c62122698')
+
+build() {
+ cd "${srcdir}/${pkgname}-2015-10-R1/"
+ mkdir build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=${pkgdir}/usr ..
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-2015-10-R1/build/"
+ make install
+}