summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD3
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f750a5946c83..02e6ee2b74dd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Mar 15 11:40:25 UTC 2017
+# Mon Apr 3 15:21:57 UTC 2017
pkgbase = libc++
pkgver = 4.0.0
- pkgrel = 1
+ pkgrel = 2
url = http://libcxx.llvm.org/
arch = i686
arch = x86_64
@@ -34,12 +34,12 @@ pkgbase = libc++
pkgname = libc++
pkgdesc = A new implementation of the C++ standard library, targeting C++11.
- depends = libc++abi=4.0.0-1
+ depends = libc++abi=4.0.0-2
pkgname = libc++abi
pkgdesc = A new implementation of low level support for a standard C++ library
pkgname = libc++experimental
pkgdesc = A new implementation of the C++ standard library, targeting C++11 (experimental library)
- depends = libc++=4.0.0-1
+ depends = libc++=4.0.0-2
diff --git a/PKGBUILD b/PKGBUILD
index 24ec1a3766a6..2bd334b6e663 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgbase=libc++
pkgname=(${pkgbase}{,abi,experimental})
pkgver=4.0.0
-pkgrel=1
+pkgrel=2
url="http://libcxx.llvm.org/"
license=('MIT' 'custom:University of Illinois/NCSA Open Source License')
arch=('i686' 'x86_64')
@@ -71,6 +71,7 @@ package_libc++abi() {
pkgdesc='A new implementation of low level support for a standard C++ library'
cd ${srcdir}/build
make DESTDIR="${pkgdir}" install-libcxxabi
+ install -Dm644 ${srcdir}/build/include/c++/v1/cxxabi.h "${pkgdir}/usr/include/c++/v1/cxxabi.h"
install -Dm644 ${srcdir}/llvm/projects/libcxxabi/CREDITS.TXT "${pkgdir}/usr/share/licenses/${pkgname}/CREDITS"
install -Dm644 ${srcdir}/llvm/projects/libcxxabi/LICENSE.TXT "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}