summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD46
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e5927c45d002
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = libcaer-git
+ pkgdesc = Minimal C library to access, configure and get data from neuromorphic sensors and processors.
+ pkgver = 1
+ pkgrel = 1
+ url = https://gitlab.com/inivation/libcaer/
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ arch = aarch64
+ license = BSD
+ makedepends = git
+ makedepends = cmake
+ makedepends = pkgconf
+ depends = libusb
+ depends = libserialport
+ depends = opencv
+ provides = libcaer
+ conflicts = libcaer
+ options = staticlibs
+ source = libcaer-git::git+https://gitlab.com/inivation/libcaer.git
+ sha256sums = SKIP
+
+pkgname = libcaer-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1e8f6e8a42ba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: iniVation AG <support@inivation.com>
+
+pkgname=libcaer-git
+pkgver=1
+pkgrel=1
+pkgdesc="Minimal C library to access, configure and get data from neuromorphic sensors and processors."
+url="https://gitlab.com/inivation/${pkgname%-git}/"
+license=('BSD')
+arch=('i686' 'x86_64' 'armv7h' 'aarch64')
+groups=()
+depends=('libusb' 'libserialport' 'opencv')
+makedepends=('git' 'cmake' 'pkgconf')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=()
+options=('staticlibs')
+source=("$pkgname::git+https://gitlab.com/inivation/${pkgname%-git}.git")
+noextract=()
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+
+ # Git, tags available
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib -DENABLE_SERIALDEV=1 -DENABLE_OPENCV=1 -DENABLE_STATIC=1 -DUDEV_INSTALL=1 -DUDEV_SELINUX=0 .
+
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+
+ DESTDIR="$pkgdir/" make install
+
+ cd "$pkgdir"
+
+ # Fix udev directory due to symlinks
+ mv lib/udev/ usr/lib/
+ rm -Rf lib/
+}