summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d8363f696da3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = libcangjie
+ pkgdesc = CangJie Input Method Library
+ pkgver = 1.3
+ pkgrel = 1
+ url = http://cangjians.github.io/projects/libcangjie/
+ arch = x86_64
+ arch = i686
+ license = LGPL3
+ makedepends = pkg-config
+ depends = sqlite
+ replaces = libcangjie-git
+ source = https://github.com/Cangjians/libcangjie/releases/download/v1.3/libcangjie-1.3.tar.xz
+ sha256sums = f4b9a0cf8673f49adb22b675992360799d66eb8d5bce2bd603358de78509d30b
+
+pkgname = libcangjie
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..602ab480da7f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Antony Ho <ntonyworkshop@gmail.com>
+pkgname=libcangjie
+pkgver=1.3
+pkgrel=1
+pkgdesc="CangJie Input Method Library"
+arch=('x86_64' 'i686')
+url="http://cangjians.github.io/projects/libcangjie/"
+license=('LGPL3')
+depends=('sqlite')
+makedepends=('pkg-config')
+replaces=('libcangjie-git')
+sha256sums=('f4b9a0cf8673f49adb22b675992360799d66eb8d5bce2bd603358de78509d30b')
+source=("https://github.com/Cangjians/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.xz")
+
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}