summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0b9d2b3022b0..d731c3e6d8ce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libcloudstorage-git
pkgdesc = C++ library providing access to files located in various cloud services
- pkgver = 1.2.r385.gf7b5d81
- pkgrel = 2
+ pkgver = 1.2.r386.gff4e9f0
+ pkgrel = 1
url = https://code.videolan.org/videolan/libcloudstorage
arch = i686
arch = x86_64
@@ -16,7 +16,7 @@ pkgbase = libcloudstorage-git
depends = libmicrohttpd
depends = mega-sdk
depends = tinyxml2
- provides = libcloudstorage
+ provides = libcloudstorage=1.2.r386.gff4e9f0
conflicts = libcloudstorage
source = git+https://code.videolan.org/videolan/libcloudstorage.git
source = 0001-Fix-compilation-with-newer-crypto.patch
@@ -24,4 +24,3 @@ pkgbase = libcloudstorage-git
sha256sums = 6e44c6986af6b1717fca2287324c58264266ab8e80d5aabb55f50f04dd7f22de
pkgname = libcloudstorage-git
-
diff --git a/PKGBUILD b/PKGBUILD
index bb25f0dcc549..78a022680461 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=libcloudstorage-git
-pkgver=1.2.r385.gf7b5d81
-pkgrel=2
+pkgver=1.2.r386.gff4e9f0
+pkgrel=1
pkgdesc="C++ library providing access to files located in various cloud services"
arch=('i686' 'x86_64')
url="https://code.videolan.org/videolan/libcloudstorage"
license=('LGPL')
depends=('boost-libs' 'crypto++' 'curl' 'fuse3' 'jsoncpp' 'libmicrohttpd' 'mega-sdk' 'tinyxml2')
makedepends=('git' 'boost')
-provides=('libcloudstorage')
+provides=("libcloudstorage=$pkgver")
conflicts=('libcloudstorage')
source=("git+https://code.videolan.org/videolan/libcloudstorage.git"
"0001-Fix-compilation-with-newer-crypto.patch")
@@ -21,7 +21,8 @@ prepare() {
cd "libcloudstorage"
patch -Np1 -i "$srcdir/0001-Fix-compilation-with-newer-crypto.patch"
- git submodule update --init
+
+ git submodule update --init --recursive
}
pkgver() {