summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD27
2 files changed, 18 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f9046420c797..16b60c537233 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
pkgbase = libcstl
pkgdesc = A common data structure and used algorithms C library
pkgver = 2.3.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/activesys/libcstl
- arch = i686
arch = x86_64
- license = LGPL
+ license = LGPL2.1
depends = glibc
- options = !libtool
- source = http://libcstl.org/downloads/libcstl-2.3.0.tar.gz
- md5sums = a509a7157bf763187d358376d8cf8e49
+ provides = libcstl.so
+ source = libcstl-2.3.0.tar.gz::https://github.com/activesys/libcstl/archive/v2.3.0.tar.gz
+ sha256sums = 1b67654554b6293989201703062c54202b8c73ca5455135c7f22762076c6b89c
pkgname = libcstl
-
diff --git a/PKGBUILD b/PKGBUILD
index 008b926b6a11..80071acd3adb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,25 @@
-# Maintainer: banbanchs <memory.silentvoyage@gmail.com>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: banbanchs <memory.silentvoyage@gmail.com>
pkgname=libcstl
pkgver=2.3.0
-pkgrel=1
+pkgrel=2
pkgdesc="A common data structure and used algorithms C library"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="https://github.com/activesys/libcstl"
-license=('LGPL')
+license=('LGPL2.1')
depends=('glibc')
-options=(!libtool)
-source=(http://libcstl.org/downloads/$pkgname-$pkgver.tar.gz)
-noextract=()
-md5sums=('a509a7157bf763187d358376d8cf8e49')
+provides=("$pkgname.so")
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('1b67654554b6293989201703062c54202b8c73ca5455135c7f22762076c6b89c')
build() {
- cd "$srcdir/$pkgname-$pkgver"
- ./configure --prefix=/usr
- make
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
- make DESTDIR="$pkgdir/" install
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
}
-