summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rwxr-xr-xPKGBUILD11
2 files changed, 9 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9de10bccceeb..9d975e860694 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sun Jan 21 13:33:42 UTC 2018
pkgbase = libcsuper
pkgdesc = Universal points counter allowing reflexion exemption - Library
- pkgver = 4.4.1
+ pkgver = 4.4.3
pkgrel = 1
url = https://www.dalan.fr
install = INSTALL
@@ -14,8 +12,7 @@ pkgbase = libcsuper
depends = muparser
depends = podofo
depends = cairo
- source = https://www.binaries.dalan.fr/Csuper/4.4.1/csuper-4.4.1-sources.tar.xz
- sha512sums = 2ac8906142c91509814719b843b4047ed9c30200531de973beced4551bf225e112e22c3457c156309c33b036752647c12380fa51e9e46a3e363310bea35a10f1
+ source = https://www.binaries.dalan.fr/Csuper/4.4.3/csuper-4.4.3-1-sources.tar.xz
+ sha512sums = 5fbf3eb8f18a26543dfc3a9beffc7b79bd150daec4b73d9a0b4cc16b0b2f8826b9dc6f6dfc548ed0262ce0bb5badf2ab94b95f00be0abfd3911307df429c3d80
pkgname = libcsuper
-
diff --git a/PKGBUILD b/PKGBUILD
index df4176fa8569..f5a33792b849 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Rémi BERTHO <remi.bertho@dalan.fr>
# Contributor: Rémi BERTHO <remi.bertho@dalan.fr>
pkgname=libcsuper
-pkgver=4.4.1
+pkgver=4.4.3
+pkgbuild=1
pkgrel=1
pkgdesc="Universal points counter allowing reflexion exemption - Library"
arch=(any)
@@ -10,12 +11,12 @@ license=('GPL')
depends=('libxml++' 'glibmm' 'muparser' 'podofo' 'cairo')
makedepends=('cmake')
install="INSTALL"
-source=(https://www.binaries.dalan.fr/Csuper/$pkgver/csuper-$pkgver-sources.tar.xz)
-sha512sums=('2ac8906142c91509814719b843b4047ed9c30200531de973beced4551bf225e112e22c3457c156309c33b036752647c12380fa51e9e46a3e363310bea35a10f1')
+source=(https://www.binaries.dalan.fr/Csuper/$pkgver/csuper-$pkgver-$pkgbuild-sources.tar.xz)
+sha512sums=('5fbf3eb8f18a26543dfc3a9beffc7b79bd150daec4b73d9a0b4cc16b0b2f8826b9dc6f6dfc548ed0262ce0bb5badf2ab94b95f00be0abfd3911307df429c3d80')
build()
{
- cd "$srcdir/csuper-$pkgver-sources"
+ cd "$srcdir/csuper-$pkgver-$pkgbuild-sources"
cmake -G"Unix Makefiles" \
-DALL_UPDATES=FALSE \
-DCMAKE_BUILD_TYPE=Release \
@@ -30,6 +31,6 @@ build()
package()
{
- cd "$srcdir/csuper-$pkgver-sources"
+ cd "$srcdir/csuper-$pkgver-$pkgbuild-sources"
make install DESTDIR="${pkgdir}"
}