summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD11
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 07502ca460cd..df17c9e149b9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Sep 10 14:39:30 UTC 2017
+# Tue Aug 14 08:15:39 UTC 2018
pkgbase = libdap
pkgdesc = A library which contains an implementation of DAP 2.0 and 3.1
- pkgver = 3.18.1
- pkgrel = 2
+ pkgver = 3.19.1
+ pkgrel = 1
url = https://www.opendap.org/index.php/software/libdap
arch = i686
arch = x86_64
@@ -11,8 +11,9 @@ pkgbase = libdap
depends = curl
depends = libxml2
depends = util-linux
- source = http://www.opendap.org/pub/source/libdap-3.18.1.tar.gz
- md5sums = 9bdca37f89dca3e1df2239ceb32f74a8
+ depends = libtirpc
+ source = http://www.opendap.org/pub/source/libdap-3.19.1.tar.gz
+ md5sums = ff0ac49bceae75fa27f38fffc5a22660
pkgname = libdap
diff --git a/PKGBUILD b/PKGBUILD
index 825ed58b4150..8b6058fdda4a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
#Contributor: Nathan O <ndowens.aur at gmail dot com>
pkgname=libdap
-pkgver=3.18.1
-pkgrel=2
+pkgver=3.19.1
+pkgrel=1
pkgdesc="A library which contains an implementation of DAP 2.0 and 3.1"
arch=('i686' 'x86_64')
url="https://www.opendap.org/index.php/software/libdap"
license=('LGPL2.1')
-depends=('curl' 'libxml2' 'util-linux')
+depends=('curl' 'libxml2' 'util-linux' 'libtirpc')
source=(http://www.opendap.org/pub/source/${pkgname}-${pkgver}.tar.gz)
-md5sums=('9bdca37f89dca3e1df2239ceb32f74a8')
+md5sums=('ff0ac49bceae75fa27f38fffc5a22660')
build() {
cd ${srcdir}/${pkgname}-${pkgver}
- ./configure --prefix=/usr
+ ./configure --prefix=/usr CPPFLAGS="$CPPFLAGS -I/usr/include/tirpc" \
+ LIBS='-ltirpc'
make
make check
}