summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1b000c53f80f..23ed0d743ae1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libdecor-git
pkgdesc = Client-side decorations library for Wayland clients
- pkgver = 0.1.0+60+g3f3e5e1
+ pkgver = 0.2.0
pkgrel = 1
url = https://gitlab.freedesktop.org/libdecor/libdecor
arch = x86_64
@@ -9,11 +9,13 @@ pkgbase = libdecor-git
makedepends = ninja
makedepends = meson
makedepends = wayland-protocols
+ makedepends = git
depends = wayland
depends = pango
depends = dbus
depends = egl-wayland
depends = libxkbcommon
+ depends = gtk3
provides = libdecor
conflicts = libdecor
source = git+https://gitlab.freedesktop.org/libdecor/libdecor.git
diff --git a/PKGBUILD b/PKGBUILD
index 404b1aa95e9f..ded7c100d932 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,13 +5,13 @@
pkgdesc='Client-side decorations library for Wayland clients'
pkgname=libdecor-git
_pkgname=libdecor
-pkgver=0.1.0+60+g3f3e5e1
+pkgver=0.2.0
pkgrel=1
url="https://gitlab.freedesktop.org/libdecor/libdecor"
license=('MIT')
arch=('x86_64')
-depends=('wayland' 'pango' 'dbus' 'egl-wayland' 'libxkbcommon')
-makedepends=('cmake' 'ninja' 'meson' 'wayland-protocols>=1.32')
+depends=('wayland' 'pango' 'dbus' 'egl-wayland' 'libxkbcommon' 'gtk3')
+makedepends=('cmake' 'ninja' 'meson' 'wayland-protocols' 'git')
source=("git+https://gitlab.freedesktop.org/libdecor/libdecor.git")
sha512sums=('SKIP')
conflicts=('libdecor')
@@ -34,6 +34,6 @@ check () {
package () {
meson install -C _build --destdir "${pkgdir}"
- install -Dm644 "${_pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ install -Dm644 "${_pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}