summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 6 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 11896845103a..43b0ef137b62 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libdispatch
pkgdesc = Comprehensive support for concurrent code execution on multicore hardware
pkgver = 5.1.4
- pkgrel = 1
+ pkgrel = 2
url = https://apple.github.io/swift-corelibs-libdispatch
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index a04c1a998efd..4678d80e830d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
pkgname=libdispatch
pkgver=5.1.4
-pkgrel=1
+pkgrel=2
pkgdesc='Comprehensive support for concurrent code execution on multicore hardware'
arch=(i686 x86_64 arm armv6h armv7h aarch64)
url=https://apple.github.io/swift-corelibs-libdispatch
@@ -20,22 +20,19 @@ prepare () {
}
build () {
- rm -rf _build
- mkdir _build
- cd _build
- CC=clang CXX=clang++ cmake \
+ CC=clang CXX=clang++ cmake -H"${pkgname}" -Bbuild \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DBlocksRuntime_INCLUDE_DIR=/usr/include \
-DBlocksRuntime_LIBRARIES=/usr/lib/libBlocksRuntime.so \
"../${pkgname}"
- cmake --build . -j $(nproc)
+ cmake --build build -j $(nproc)
}
check () {
- cmake --build _build --target test
+ cmake --build build --target test
}
package () {
- DESTDIR="${pkgdir}" cmake --install _build
+ DESTDIR="${pkgdir}" cmake --install build
}