summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD2
-rw-r--r--gnustep-blocks.patch2
2 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fcb326b56e7f..fe0b2d547a1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_gitname=libdispatch
pkgname=$_gitname-clang-git
pkgver=301.4e4b38f
-pkgrel=5
+pkgrel=6
pkgdesc="Linux port of Apple's open-source concurrency library with blocks support, using Clang"
arch=('i686' 'x86_64')
url="http://nickhutchinson.me/libdispatch"
diff --git a/gnustep-blocks.patch b/gnustep-blocks.patch
index 34d2c2c87e81..bfea6c999d6e 100644
--- a/gnustep-blocks.patch
+++ b/gnustep-blocks.patch
@@ -23,7 +23,7 @@
check_function_exists(BLOCKS_RUNTIME_RUNTIME_IN_LIBC _Block_copy)
if (NOT BLOCKS_RUNTIME_RUNTIME_IN_LIBC)
- find_library(BLOCKS_RUNTIME_LIBRARIES "BlocksRuntime")
-+ set(CBLOCKS_LIBRARIES "-l:libobjc.so.4.6")
++ set(BLOCKS_RUNTIME_LIBRARIES "-l:libobjc2.so.4.6")
endif ()
if (BLOCKS_RUNTIME_LIBRARIES OR BLOCKS_RUNTIME_RUNTIME_IN_LIBC)