summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--COPYING48
-rw-r--r--PKGBUILD58
3 files changed, 129 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c193cb1f854b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = libdrm-minimal-git
+ pkgdesc = Userspace interface to kernel DRM services, master git version
+ pkgver = 2.4.100.r68.g8a73372e
+ pkgrel = 1
+ url = http://dri.freedesktop.org/
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = libxslt
+ makedepends = meson
+ makedepends = git
+ makedepends = ninja
+ depends = libpciaccess
+ provides = libdrm
+ provides = libdrm-git
+ conflicts = libdrm
+ source = libdrm::git://anongit.freedesktop.org/mesa/drm#branch=master
+ source = COPYING
+ sha512sums = SKIP
+ sha512sums = b0ca349b882a4326b19f81f22804fabdb6fb7aef31cdc7b16b0a7ae191bfbb50c7daddb2fc4e6c33f1136af06d060a273de36f6f3412ea326f16fa4309fda660
+
+pkgname = libdrm-minimal-git
+
diff --git a/COPYING b/COPYING
new file mode 100644
index 000000000000..6e74c337c3b9
--- /dev/null
+++ b/COPYING
@@ -0,0 +1,48 @@
+ Copyright 2005 Adam Jackson.
+
+ Permission is hereby granted, free of charge, to any person obtaining
+ a copy of this software and associated documentation files (the
+ "Software"), to deal in the Software without restriction, including
+ without limitation on the rights to use, copy, modify, merge,
+ publish, distribute, sub license, and/or sell copies of the Software,
+ and to permit persons to whom the Software is furnished to do so,
+ subject to the following conditions:
+
+ The above copyright notice and this permission notice (including the
+ next paragraph) shall be included in all copies or substantial
+ portions of the Software.
+
+ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+ EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+ MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+ NON-INFRINGEMENT. IN NO EVENT SHALL ADAM JACKSON BE LIABLE FOR ANY
+ CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT,
+ TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
+ SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+------------------------------------------------------------------------
+
+ Copyright 1999 Precision Insight, Inc., Cedar Park, Texas.
+ Copyright 2000 VA Linux Systems, Inc., Sunnyvale, California.
+ All Rights Reserved.
+
+ Permission is hereby granted, free of charge, to any person obtaining
+ a copy of this software and associated documentation files (the
+ "Software"), to deal in the Software without restriction, including
+ without limitation the rights to use, copy, modify, merge, publish,
+ distribute, sublicense, and/or sell copies of the Software, and to
+ permit persons to whom the Software is furnished to do so, subject to
+ the following conditions:
+
+ The above copyright notice and this permission notice (including the
+ next paragraph) shall be included in all copies or substantial
+ portions of the Software.
+
+ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+ EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+ MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+ NONINFRINGEMENT. IN NO EVENT SHALL PRECISION INSIGHT AND/OR ITS
+ SUPPLIERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
+ WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+ OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+ DEALINGS IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..564d1ff6a958
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer : Vincent Grande <shoober420@gmail.com>
+# Contributor : Lone_Wolf <lone_wolf@klaas-de-kat.nl>
+# Contributor : Eric Engestrom <eric@engestrom.ch>
+# Contributor : Jan de Groot <jgc@archlinux.org>
+
+pkgname=libdrm-minimal-git
+_realname=libdrm
+pkgver=2.4.100.r68.g8a73372e
+pkgrel=1
+pkgdesc="Userspace interface to kernel DRM services, master git version"
+arch=(i686 x86_64)
+license=('custom')
+depends=('libpciaccess')
+makedepends=('libxslt' 'meson' 'git' 'ninja')
+#checkdepends=('cairo' 'cunit')
+url="http://dri.freedesktop.org/"
+provides=('libdrm' 'libdrm-git')
+conflicts=('libdrm')
+
+source=('libdrm::git://anongit.freedesktop.org/mesa/drm#branch=master'
+ COPYING)
+sha512sums=('SKIP'
+ 'b0ca349b882a4326b19f81f22804fabdb6fb7aef31cdc7b16b0a7ae191bfbb50c7daddb2fc4e6c33f1136af06d060a273de36f6f3412ea326f16fa4309fda660')
+
+pkgver() {
+ cd $_realname
+ git describe --long --abbrev=8 | sed 's/^libdrm-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ if [ -d _build ]; then
+ rm -rf _build
+ fi
+}
+
+build() {
+ meson setup libdrm _build \
+ --prefix /usr \
+ --buildtype plain \
+ --wrap-mode nofallback \
+ -D udev=false \
+ -D valgrind=false \
+ -D man-pages=false
+ meson configure _build
+ ninja $NINJAFLAGS -C _build
+}
+
+#check() {
+ # '-t 10' is needed for the 'threaded' test, which uses the default meson
+ # test timeout of 30 seconds. This is too short for many systems. It can be
+ # removed if upstream fixes the issue.
+# meson test -C _build -t 10
+#}
+
+package() {
+ DESTDIR="$pkgdir" ninja $NINJAFLAGS -C _build install
+ install -Dt "$pkgdir"/usr/share/licenses/"$pkgname" -m644 COPYING
+}