summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 014777fbd9a3..a4bfcabadd7c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Thu Apr 12 13:52:48 UTC 2018
pkgbase = libdvd-audio-git
pkgdesc = A C library for extracting audio from DVD-Audio discs. (GIT version)
- pkgver = v1.0.0.3.gc74bdfc
+ pkgver = 1.0.0.3.gc74bdfc
pkgrel = 1
url = http://libdvd-audio.sourceforge.net
arch = x86_64
@@ -11,8 +9,8 @@ pkgbase = libdvd-audio-git
depends = glibc
provides = libdvd-audio
conflicts = libdvd-audio
+ options = debug
source = git+https://github.com/tuffy/libdvd-audio.git
sha256sums = SKIP
pkgname = libdvd-audio-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 96f1c5f9697a..dee0d88c1d29 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
pkgname=libdvd-audio-git
-pkgver=v1.0.0.3.gc74bdfc
+pkgver=1.0.0.3.gc74bdfc
pkgrel=1
pkgdesc="A C library for extracting audio from DVD-Audio discs. (GIT version)"
arch=('x86_64')
@@ -13,10 +13,11 @@ provides=('libdvd-audio')
conflicts=('libdvd-audio')
source=('git+https://github.com/tuffy/libdvd-audio.git')
sha256sums=('SKIP')
+options=('debug')
pkgver() {
cd libdvd-audio
- echo "$(git describe --always | tr - .)"
+ echo "$(git describe --always | tr - . | tr -d v)"
}
build() {
@@ -27,5 +28,11 @@ build() {
package() {
cd libdvd-audio
install -d ${pkgdir}/usr/{include,bin,lib{,/pkgconfig}}
- make BIN_DIR=${pkgdir}/usr/bin LIB_DIR=${pkgdir}/usr/lib INCLUDE_DIR=${pkgdir}/usr/include LIB_DIR=${pkgdir}/usr/lib PKG_CONFIG_DIR=${pkgdir}/usr/lib/pkgconfig install
+ make \
+ BIN_DIR="${pkgdir}/usr/bin" \
+ LIB_DIR="${pkgdir}/usr/lib" \
+ INCLUDE_DIR="${pkgdir}/usr/include" \
+ LIB_DIR="${pkgdir}/usr/lib" \
+ PKG_CONFIG_DIR="${pkgdir}/usr/lib/pkgconfig" \
+ install
}