summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 16 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 516557f41817..4d8013f648ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = libeconf
pkgdesc = Enhanced config file parser, which merges config files placed in several locations into one.
- pkgver = 0.4.9
+ pkgver = 0.6.0
pkgrel = 1
url = https://opensuse.github.io/libeconf/
arch = x86_64
license = MIT
makedepends = meson
- source = libeconf-0.4.9.tar.gz::https://github.com/openSUSE/libeconf/archive/refs/tags/v0.4.9.tar.gz
- md5sums = c2523f6987c436a44b92917a028cbf7c
+ source = libeconf-0.6.0.tar.gz::https://github.com/openSUSE/libeconf/archive/refs/tags/v0.6.0.tar.gz
+ source = https://github.com/openSUSE/libeconf/commit/1eef99e3144811c0acf905bb2e67a78633ee6eaf.patch
+ sha256sums = 766da6c606e33d9bc8ff0a4f4b72ce11a236d6cb046f21ebb9c4c6a9d078fff2
+ sha256sums = 516761a2d64958f0845eee14bb61cf665f2c0bc139b97491673aee04276ce177
pkgname = libeconf
diff --git a/PKGBUILD b/PKGBUILD
index 363e8e318305..86030b113698 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Thomas Weißschuh <thomas t-8ch de>
pkgname=libeconf
-pkgver=0.4.9
+pkgver=0.6.0
pkgrel=1
pkgdesc="Enhanced config file parser, which merges config files placed in several locations into one."
arch=(x86_64)
@@ -9,8 +9,16 @@ url="https://opensuse.github.io/libeconf/"
license=('MIT')
depends=()
makedepends=(meson)
-source=("$pkgname-$pkgver.tar.gz::https://github.com/openSUSE/${pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
-md5sums=('c2523f6987c436a44b92917a028cbf7c')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/openSUSE/${pkgname}/archive/refs/tags/v${pkgver}.tar.gz"
+ "https://github.com/openSUSE/libeconf/commit/1eef99e3144811c0acf905bb2e67a78633ee6eaf.patch")
+sha256sums=('766da6c606e33d9bc8ff0a4f4b72ce11a236d6cb046f21ebb9c4c6a9d078fff2'
+ '516761a2d64958f0845eee14bb61cf665f2c0bc139b97491673aee04276ce177')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+
+ patch -p1 < "$srcdir"/1eef99e3144811c0acf905bb2e67a78633ee6eaf.patch
+}
build() {
cd "$pkgname-$pkgver"