summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD29
2 files changed, 24 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03e8ecfa220e..fdab8b80e744 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
# Generated by mksrcinfo v8
-# Sun Jan 10 21:16:02 UTC 2016
+# Sat Apr 8 14:24:14 UTC 2017
pkgbase = libemf
- pkgdesc = ECMA-234 Metafile Library
+ pkgdesc = Library implementation of ECMA-234 API for the generation of enhanced metafiles.
pkgver = 1.0.8
- pkgrel = 0
+ pkgrel = 1
url = http://libemf.sourceforge.net/
arch = i686
arch = x86_64
- license = LGPL2
+ license = LGPL2.1
+ provides = libEMF.so
source = http://sourceforge.net/projects/libemf/files/libemf/1.0.8/libemf-1.0.8.tar.gz
sha256sums = ee0324f705136a4d3343c2f0c3e5fa526fae0ec3680a96400d5fd209c60a3891
diff --git a/PKGBUILD b/PKGBUILD
index e29a4970c4c9..d025b0882836 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,30 @@
-# Maintainer: lily wilson <hotaru@thinkindifferent.net>
+# Maintainer : Daniel Bermond < yahoo-com: danielbermond >
+# Contributor: lily wilson <hotaru@thinkindifferent.net>
+
pkgname=libemf
pkgver=1.0.8
-pkgrel=0
-pkgdesc="ECMA-234 Metafile Library"
+pkgrel=1
+pkgdesc="Library implementation of ECMA-234 API for the generation of enhanced metafiles."
arch=('i686' 'x86_64')
url="http://libemf.sourceforge.net/"
-license=('LGPL2')
-source=("http://sourceforge.net/projects/$pkgname/files/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz")
+license=('LGPL2.1')
+provides=('libEMF.so')
+source=("http://sourceforge.net/projects/${pkgname}/files/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz")
sha256sums=('ee0324f705136a4d3343c2f0c3e5fa526fae0ec3680a96400d5fd209c60a3891')
build() {
- cd $srcdir/$pkgname-$pkgver
- ./configure --prefix=/usr
- make || return 1
+ cd "${pkgname}-${pkgver}"
+ ./configure \
+ --prefix=/usr \
+ --enable-static=no \
+ --enable-shared=yes \
+ --enable-fast-install \
+ --enable-threads \
+ --enable-editing
+ make
}
package() {
- cd $srcdir/$pkgname-$pkgver
- make DESTDIR=$pkgdir install
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR="$pkgdir" install
}