summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD43
2 files changed, 30 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 783f756cdf94..4bfdfa718fa5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,21 @@
pkgbase = libepoxy-git
- pkgdesc = Epoxy is a library for handling OpenGL function pointer management for you
- pkgver = 1.5.4.r20.g34ecb90
+ pkgdesc = Library handling OpenGL function pointer management
+ pkgver = 1.5.4+20+g34ecb90
pkgrel = 1
url = https://github.com/anholt/libepoxy
- arch = i686
arch = x86_64
- license = BSD
- makedepends = xorg-util-macros
- makedepends = libx11
+ license = MIT
makedepends = python
+ makedepends = mesa-libgl
makedepends = git
makedepends = meson
+ makedepends = doxygen
+ makedepends = graphviz
+ depends = glibc
provides = libepoxy
conflicts = libepoxy
source = git+https://github.com/anholt/libepoxy.git
- md5sums = SKIP
+ sha256sums = SKIP
pkgname = libepoxy-git
diff --git a/PKGBUILD b/PKGBUILD
index 7ff2fbcec0d5..6a0ca088d4af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,39 @@
+# Maintainer: Christoph Haag <christoph.haag@collabora.com>
+# Contributor: Laurent Carlier <lordheavym@gmail.com>
+
pkgname=libepoxy-git
-_name=libepoxy
-pkgver=1.5.4.r20.g34ecb90
+pkgver=1.5.4+20+g34ecb90
pkgrel=1
-pkgdesc="Epoxy is a library for handling OpenGL function pointer management for you"
+pkgdesc="Library handling OpenGL function pointer management"
url="https://github.com/anholt/libepoxy"
-arch=('i686' 'x86_64')
-license=('BSD')
-makedepends=("xorg-util-macros" "libx11" "python" "git" "meson")
+arch=(x86_64)
+license=(MIT)
+depends=(glibc)
+makedepends=(python mesa-libgl git meson doxygen graphviz)
provides=("libepoxy")
conflicts=("libepoxy")
source=("git+https://github.com/anholt/libepoxy.git")
-md5sums=('SKIP')
+sha256sums=('SKIP')
pkgver() {
- cd $_name
+ cd libepoxy
+ git describe --tags | sed 's/-/+/g'
+}
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+prepare() {
+ cd libepoxy
}
build() {
- cd "$_name"
-
- rm -rf _build
- meson _build --buildtype=release --prefix=/usr --libdir=/usr/lib
- ninja -C _build
+ arch-meson libepoxy build -D docs=true --libdir="lib"
+ ninja -C build
}
-#check() {
-# cd "$_name/_build"
-#
-# ninja test
-#}
+check() {
+ meson test -C build --print-errorlogs
+}
package() {
- cd "$_name/_build"
- env DESTDIR="$pkgdir" ninja install
+ DESTDIR="$pkgdir" meson install -C build
+ install -Dm644 libepoxy/COPYING "$pkgdir/usr/share/licenses/libepoxy/LICENSE"
}