summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0570f19f2042
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = libespm-git
+ pkgdesc = Library for reading and writing .esp and .esm plugin files.
+ pkgver = r207.fe6b7b8
+ pkgrel = 1
+ url = https://github.com/WrinklyNinja/libespm
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = boost-libs
+ provides = libespm
+ conflicts = libespm
+ source = git+https://github.com/WrinklyNinja/libespm.git
+ md5sums = SKIP
+
+pkgname = libespm-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2c63aaa281e2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Frederik “Freso” S. Olesen <freso.dk@gmail.com>
+_pkgname=libespm
+pkgname=$_pkgname-git
+pkgver=r207.fe6b7b8
+pkgrel=1
+pkgdesc='Library for reading and writing .esp and .esm plugin files.'
+arch=('any')
+url="https://github.com/WrinklyNinja/$_pkgname"
+license=('GPL3')
+depends=('boost-libs')
+makedepends=('git')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+$url.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ git checkout-index -a --prefix="$pkgdir/usr/include/$_pkgname/"
+}