summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD35
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..456cb3edd77a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = libflame-git
+ pkgdesc = High-performance object-based library for DLA computations
+ pkgver = r78.b0936fbe
+ pkgrel = 1
+ url = https://github.com/flame/libflame
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ makedepends = make
+ makedepends = gcc
+ depends = blas
+ depends = lapack
+ provides = libflame
+ conflicts = libflame
+ options = staticlibs
+ source = libflame-git::git+https://github.com/flame/libflame.git
+ sha1sums = SKIP
+
+pkgname = libflame-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8dcfd8f52348
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+
+pkgname=libflame-git
+pkgver=r78.b0936fbe
+pkgrel=1
+pkgdesc="High-performance object-based library for DLA computations"
+arch=('i686' 'x86_64')
+license=('BSD')
+url="https://github.com/flame/libflame"
+depends=('blas' 'lapack')
+makedepends=('git' 'make' 'gcc')
+provides=('libflame')
+conflicts=('libflame')
+source=("$pkgname::git+https://github.com/flame/libflame.git")
+sha1sums=('SKIP')
+options=('staticlibs')
+
+pkgver() {
+ cd "${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${pkgname}"
+
+ # static build is necessary for some packages and programs (e. g. GAMESS)
+ ./configure --prefix=/usr --enable-static-build --enable-dynamic-build --enable-multithreading=openmp --enable-supermatrix --enable-max-arg-list-hack
+ make
+}
+
+package() {
+ cd "${pkgname}"
+
+ make DESTDIR="${pkgdir}" install
+}