summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD45
2 files changed, 29 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc1add95ff96..a50926f7ce5b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,20 @@
pkgbase = libgee-git
- pkgdesc = GObject collection library
- pkgver = 0.12.0.428.f71b18a
+ pkgdesc = A collection library providing GObject-based interfaces and classes for commonly used data structures
+ pkgver = 0.20.1.r0.g57e4c8a
pkgrel = 1
- url = http://live.gnome.org/Libgee
+ url = https://git.gnome.org/browse/libgee
arch = i686
arch = x86_64
license = LGPL2.1
makedepends = gobject-introspection
makedepends = vala
- makedepends = gnome-common
+ makedepends = autoconf-archive
+ makedepends = git
+ makedepends = valadoc
depends = glib2
- provides = libgee=0.12.0.428.f71b18a
+ provides = libgee
conflicts = libgee
- source = git+git://git.gnome.org/libgee
+ source = git+https://git.gnome.org/browse/libgee
sha256sums = SKIP
pkgname = libgee-git
diff --git a/PKGBUILD b/PKGBUILD
index 7003230520d7..a78a8917a52d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,46 @@
-# $Id: PKGBUILD 198163 2013-10-30 13:10:44Z allan $
-# Original Package : Ionut Biru <ibiru@archlinux.org>
+# Contributor: Fabio 'Lolix' Loli <lolix@disroot.org>
+# Contributor: Ionut Biru <ibiru@archlinux.org>
# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
-# Maintainer: Lubosz Sarnecki <lubosz@gmail.com>
+# Contributor: Lubosz Sarnecki <lubosz@gmail.com>
pkgname=libgee-git
-pkgver=0.12.0.428.f71b18a
+pkgver=0.20.1.r0.g57e4c8a
pkgrel=1
-pkgdesc="GObject collection library"
-url="http://live.gnome.org/Libgee"
+pkgdesc="A collection library providing GObject-based interfaces and classes for commonly used data structures"
+url="https://git.gnome.org/browse/libgee"
license=(LGPL2.1)
arch=(i686 x86_64)
depends=(glib2)
-makedepends=(gobject-introspection vala gnome-common)
-
-provides=('libgee='$pkgver)
-conflicts=('libgee')
-
-source='git+git://git.gnome.org/libgee'
+makedepends=(gobject-introspection vala autoconf-archive git valadoc)
+provides=(libgee)
+conflicts=(libgee)
+source=("git+https://git.gnome.org/browse/libgee")
sha256sums=('SKIP')
-_gitname='libgee'
-
pkgver() {
- cd $_gitname
- version=$(grep AC_INIT configure.ac | sed 's/AC_INIT(\[libgee\], \[//' | sed 's/\], \[https:\/\/bugzilla.gnome.org\/enter_bug.cgi?product=libgee\], \[libgee\])//')
- hash=$(git log --pretty=format:'%h' -n 1)
- revision=$(git rev-list --count HEAD)
-
- echo $version.$revision.$hash
+ cd "${pkgname/-git/}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "${pkgname/-git/}"
+ NOCONFIGURE=1 ./autogen.sh
}
build() {
- cd $_gitname
- ./autogen.sh --prefix=/usr --disable-static
+ cd "${pkgname/-git/}"
+ ./configure --prefix=/usr --disable-static
make
}
check() {
- cd $_gitname
+ cd "${pkgname/-git/}"
# generates a bazillion traps - make sure systemd's core_pattern
# is deactivated, or you'll DoS the journal and the system
#make check
}
package() {
- cd $_gitname
+ cd "${pkgname/-git/}"
make DESTDIR="$pkgdir" install
}