summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD39
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..87b60988f0d3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = libgme-git
+ pkgdesc = Video game music file emulation/playback library (git version)
+ pkgver = r215.013d467
+ pkgrel = 1
+ url = https://bitbucket.org/mpyne/game-music-emu
+ arch = x86_64
+ license = LGPL
+ makedepends = cmake
+ makedepends = git
+ depends = gcc-libs
+ depends = libunrar
+ provides = libgme
+ conflicts = libgme
+ source = game-music-emu::git+https://bitbucket.org/mpyne/game-music-emu.git
+ sha256sums = SKIP
+
+pkgname = libgme-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4853b067a83a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Jjohn Regan <john@jrjrtech.com>
+
+pkgname=libgme-git
+pkgver=r215.013d467
+pkgrel=1
+pkgdesc="Video game music file emulation/playback library (git version)"
+url="https://bitbucket.org/mpyne/game-music-emu"
+license=('LGPL')
+arch=('x86_64')
+depends=('gcc-libs' 'libunrar')
+makedepends=('cmake' 'git')
+source=('game-music-emu::git+https://bitbucket.org/mpyne/game-music-emu.git')
+sha256sums=('SKIP')
+
+provides=('libgme')
+conflicts=('libgme')
+
+pkgver() {
+ cd "$srcdir/game-music-emu"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/game-music-emu"
+ mkdir build
+ cd build
+
+ cmake .. \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_SHARED_LIBS=ON \
+ -DENABLE_UBSAN=OFF
+ make
+}
+
+package() {
+ cd "$srcdir/game-music-emu/build"
+ make DESTDIR="${pkgdir}" install
+}