summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--0001-build-with-clang.patch25
-rw-r--r--PKGBUILD10
3 files changed, 35 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 529f586aab1d..6858c42ae994 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Oct 21 03:49:16 UTC 2016
+# Fri Oct 21 15:40:42 UTC 2016
pkgbase = libgo
pkgdesc = Go-style concurrency in C++11
pkgver = 2.6
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/yyzybb537/libgo
arch = i686
arch = x86_64
@@ -11,7 +11,9 @@ pkgbase = libgo
makedepends = cmake
depends = boost
source = libgo-2.6.tar.gz::https://github.com/yyzybb537/libgo/archive/v2.6.tar.gz
+ source = 0001-build-with-clang.patch
sha512sums = 84610109a088ec100045292183d7eb7cc0ea6de16e583b9a4692d20bad0b63ab0c6206bc3f718d1afb13e4b70b139b279faa1b22c6e55610235580096c536820
+ sha512sums = 63aeab3cff2087209b607177ac76c52acc59de9b678c7151a28e18e91547c08b936e8822fb7b99fd5af5f8257ca46b13faeb5b94b0934b3280c2e173194e812b
pkgname = libgo
diff --git a/0001-build-with-clang.patch b/0001-build-with-clang.patch
new file mode 100644
index 000000000000..eabd7c156981
--- /dev/null
+++ b/0001-build-with-clang.patch
@@ -0,0 +1,25 @@
+From 16c81f69dca70544f6d9d5304970856a7610f0cb Mon Sep 17 00:00:00 2001
+From: gsc <xgdgsc@gmail.com>
+Date: Fri, 21 Oct 2016 15:50:42 +0800
+Subject: [PATCH] build with clang
+
+---
+ libgo/channel.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/libgo/channel.h b/libgo/channel.h
+index 25c2727..f888d16 100644
+--- a/libgo/channel.h
++++ b/libgo/channel.h
+@@ -4,7 +4,7 @@
+ #include <libgo/block_object.h>
+ #include <libgo/co_mutex.h>
+ #include <libgo/scheduler.h>
+-
++using std::nullptr_t;
+ namespace co
+ {
+
+--
+2.10.0
+
diff --git a/PKGBUILD b/PKGBUILD
index d862bb31e4b7..322c81bfeede 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,24 @@
pkgname=libgo
pkgver=2.6
-pkgrel=1
+pkgrel=2
pkgdesc="Go-style concurrency in C++11"
arch=('i686' 'x86_64')
url="https://github.com/yyzybb537/libgo"
license=('MIT')
depends=('boost')
makedepends=('cmake')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/yyzybb537/libgo/archive/v${pkgver}.tar.gz")
-sha512sums=('84610109a088ec100045292183d7eb7cc0ea6de16e583b9a4692d20bad0b63ab0c6206bc3f718d1afb13e4b70b139b279faa1b22c6e55610235580096c536820')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/yyzybb537/libgo/archive/v${pkgver}.tar.gz" "0001-build-with-clang.patch")
+sha512sums=('84610109a088ec100045292183d7eb7cc0ea6de16e583b9a4692d20bad0b63ab0c6206bc3f718d1afb13e4b70b139b279faa1b22c6e55610235580096c536820' '63aeab3cff2087209b607177ac76c52acc59de9b678c7151a28e18e91547c08b936e8822fb7b99fd5af5f8257ca46b13faeb5b94b0934b3280c2e173194e812b')
prepare() {
mkdir -p build
}
build() {
- cd build
+ cd ${pkgname}-${pkgver}
+ patch -p1 < ../0001-build-with-clang.patch
+ cd ../build
cmake ../${pkgname}-${pkgver} \
-DENABLE_BOOST_CONTEXT=ON \
-DENABLE_BOOST_COROUTINE=ON \