summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD46
2 files changed, 14 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d1e3e6b4a8f4..a7436f71ea26 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libgweather-git
pkgdesc = Location and timezone database and weather-lookup library
- pkgver = 4.2.0.r28.g1c3dfe68
+ pkgver = 4.4.0.r8.g57a116bf
pkgrel = 1
url = https://gitlab.gnome.org/GNOME/libgweather
arch = x86_64
@@ -16,16 +16,10 @@ pkgbase = libgweather-git
depends = json-glib
depends = libsoup3
depends = libxml2
- source = libgweather::git+https://gitlab.gnome.org/GNOME/libgweather
+ source = libgweather::git+https://gitlab.gnome.org/GNOME/libgweather.git
sha256sums = SKIP
pkgname = libgweather-git
- pkgdesc = metapackage to track broken dependencies
- depends = libgweather-4-git
- provides = libgweather
- conflicts =
-
-pkgname = libgweather-4-git
- provides = libgweather-4
+ provides = libgweather-4=4.4.0
provides = libgweather-4.so
conflicts = libgweather-4
diff --git a/PKGBUILD b/PKGBUILD
index 0a1debd055fb..0f8162fc22b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,9 @@
# Maintainer:
# Contributor: Ignacy KuchciƄski (ignapk) <ignacykuchcinski@gmail.com>
-_pkgbase="libgweather"
-pkgbase="$_pkgbase-git"
-
-case "${_srcinfo::1}" in
- 't'|'y'|1)
- pkgname=(
- "libgweather-git"
- "libgweather-4-git"
- )
- ;;
- *)
- pkgname=(
- "libgweather-4-git"
- )
- ;;
-esac
-
-pkgver=4.2.0.r28.g1c3dfe68
+_pkgname="libgweather"
+pkgname="$_pkgname-git"
+pkgver=4.4.0.r8.g57a116bf
pkgrel=1
pkgdesc='Location and timezone database and weather-lookup library'
url='https://gitlab.gnome.org/GNOME/libgweather'
@@ -41,16 +26,17 @@ makedepends=(
'vala'
)
-source=("$_pkgbase"::"git+$url")
+_pkgsrc="$_pkgname"
+source=("$_pkgsrc"::"git+$url.git")
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/$_pkgbase"
+ cd "$_pkgsrc"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- arch-meson "$_pkgbase" build -D gtk_doc=true
+ arch-meson "$_pkgsrc" build -D gtk_doc=true
meson compile -C build
}
@@ -58,24 +44,14 @@ check() {
meson test -C build --print-errorlogs || true
}
-package_libgweather-git() {
- pkgdesc='metapackage to track broken dependencies'
- depends=('libgweather-4-git')
-
- provides+=(
- 'libgweather'
- )
- conflicts=(${provides[@]})
-}
-
-package_libgweather-4-git() {
+package() {
provides+=(
- 'libgweather-4'
- 'libgweather-4.so'
+ "libgweather-4=${pkgver%%.r*}"
+ "libgweather-4.so"
)
conflicts=(
'libgweather-4'
)
- meson install -C build --destdir "$pkgdir"
+ meson install -C build --destdir "${pkgdir:?}"
}