summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD39
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a727ae5b12fe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = libgweather-git
+ pkgdesc = Location and timezone database and weather-lookup library
+ pkgver = 40.alpha.r7.g21e87d8f
+ pkgrel = 1
+ url = https://wiki.gnome.org/Projects/LibGWeather
+ arch = x86_64
+ license = LGPL
+ makedepends = gobject-introspection
+ makedepends = vala
+ makedepends = git
+ makedepends = gtk-doc
+ makedepends = glade
+ makedepends = meson
+ depends = libsoup
+ depends = gtk3
+ depends = geocode-glib
+ depends = dconf
+ provides = libgweather-3.so
+ provides = libgweather
+ conflicts = libgweather
+ source = git+https://gitlab.gnome.org/GNOME/libgweather.git
+ sha256sums = SKIP
+
+pkgname = libgweather-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b4afd4cc801b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Ignacy KuchciƄski (ignapk) <ignacykuchcinski@gmail.com>
+
+pkgname=libgweather-git
+_pkgname=libgweather
+pkgver=40.alpha.r7.g21e87d8f
+pkgrel=1
+pkgdesc="Location and timezone database and weather-lookup library"
+url="https://wiki.gnome.org/Projects/LibGWeather"
+arch=(x86_64)
+license=(LGPL)
+depends=(libsoup gtk3 geocode-glib dconf)
+makedepends=(gobject-introspection vala git gtk-doc glade meson)
+provides=(libgweather-3.so libgweather)
+conflicts=(libgweather)
+source=("git+https://gitlab.gnome.org/GNOME/libgweather.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd $_pkgname
+}
+
+build() {
+ arch-meson $_pkgname build -D gtk_doc=true
+ meson compile -C build
+}
+
+check() {
+ # Test fails without fr_FR.UTF-8 locale
+ meson test -C build --print-errorlogs || :
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}