summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD49
-rw-r--r--libgweather.install22
3 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..98ed67915618
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = libgweather2
+ pkgdesc = Provides access to weather information from the net (legacy version)
+ pkgver = 2.30.3
+ pkgrel = 2
+ url = http://www.gnome.org/
+ install = libgweather.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = pkgconfig
+ makedepends = intltool
+ makedepends = gtk-doc
+ makedepends = gobject-introspection
+ makedepends = gnome-common
+ depends = gconf
+ depends = libsoup-gnome
+ depends = gtk2
+ provides = libgweather
+ conflicts = libgweather
+ options = !libtool
+ options = !emptydirs
+ source = http://ftp.gnome.org/pub/GNOME/sources/libgweather/2.30/libgweather-2.30.3.tar.bz2
+ md5sums = bf6a0a05051341ecb250f332e3edfb88
+
+pkgname = libgweather2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ff32503215ba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Piotr Rogoża <rogoza dot piotr at gmail dot com>
+# Contributor: Piotr Rogoża <rogoza dot piotr at gmail dot com>
+# vim:set ts=2 sw=2 et ft=sh tw=100: expandtab
+
+pkgname=libgweather2
+_pkgname=libgweather
+pkgver=2.30.3
+_pkgver=${pkgver%.*}
+pkgrel=2
+pkgdesc="Provides access to weather information from the net (legacy version)"
+arch=('i686' 'x86_64')
+url="http://www.gnome.org/"
+license=('GPL')
+groups=()
+depends=(gconf libsoup-gnome gtk2)
+makedepends=('pkgconfig' 'intltool' 'gtk-doc' 'gobject-introspection' 'gnome-common')
+optdepends=()
+provides=(libgweather)
+conflicts=(libgweather)
+replaces=()
+backup=()
+options=('!libtool' '!emptydirs')
+install='libgweather.install'
+source=(http://ftp.gnome.org/pub/GNOME/sources/${_pkgname}/${_pkgver}/${_pkgname}-${pkgver}.tar.bz2)
+noextract=()
+
+build(){
+ cd "$srcdir/$_pkgname-$pkgver"
+
+ gtkdocize
+# autoreconf -fi
+
+ ./configure --prefix=/usr --sysconfdir=/etc \
+ --localstatedir=/var --disable-static \
+ --enable-locations-compression
+
+ make
+}
+package(){
+ cd "$srcdir/$_pkgname-$pkgver"
+
+ make GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 DESTDIR="${pkgdir}" install
+
+ install -m755 -d "${pkgdir}/usr/share/gconf/schemas"
+ gconf-merge-schema "${pkgdir}/usr/share/gconf/schemas/${pkgname}.schemas" --domain libgweather ${pkgdir}/etc/gconf/schemas/*.schemas
+ rm -f ${pkgdir}/etc/gconf/schemas/*.schemas
+}
+
+md5sums=('bf6a0a05051341ecb250f332e3edfb88')
diff --git a/libgweather.install b/libgweather.install
new file mode 100644
index 000000000000..9945b2dfabba
--- /dev/null
+++ b/libgweather.install
@@ -0,0 +1,22 @@
+pkgname=libgweather2
+
+post_install() {
+ usr/sbin/gconfpkg --install ${pkgname}
+ gtk-update-icon-cache -q -t -f usr/share/icons/gnome
+}
+
+pre_upgrade() {
+ pre_remove $1
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ usr/sbin/gconfpkg --uninstall ${pkgname}
+}
+
+post_remove() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/gnome
+}