summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD77
2 files changed, 65 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 20471dfdcae3..bc188f40946f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,29 +1,29 @@
-# Generated by mksrcinfo v8
-# Mon Aug 28 19:12:20 UTC 2017
pkgbase = libgxps-git
- pkgdesc = An XPS Documents library
- pkgver = 0.3.0.r0.g762b302
+ pkgdesc = XPS Documents library
+ pkgver = 0.3.2.r6.g665dc29
pkgrel = 1
- url = https://git.gnome.org/browse/libgxps/
- arch = i686
+ url = https://wiki.gnome.org/Projects/libgxps
arch = x86_64
- license = GPL
+ arch = i686
+ license = GPL2
+ makedepends = git
makedepends = gobject-introspection
makedepends = gtk-doc
- makedepends = git
+ makedepends = gtk3
makedepends = meson
- makedepends = gnome-common
- depends = gtk3
+ depends = cairo
+ depends = freetype2
+ depends = glib2
+ depends = lcms2
depends = libarchive
depends = libjpeg-turbo
+ depends = libpng
depends = libtiff
- depends = lcms2
- depends = glib2
- depends = openssl-1.0
- provides = libgxps=0.3.0
+ provides = libgxps=0.3.2
conflicts = libgxps
- source = git://git.gnome.org/libgxps
+ source = git+https://gitlab.gnome.org/GNOME/libgxps.git
+ md5sums = SKIP
sha256sums = SKIP
+ b2sums = SKIP
pkgname = libgxps-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 7f4eeb66bd8a..d3996b30d370 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,59 +1,80 @@
# Maintainer: Chris Severance aur.severach AatT spamgourmet.com
-# Contributor: Jan de Groot https://www.archlinux.org/packages/extra/x86_64/libgxps/
-# Contributor: Auguste Pop <auguste [at] gmail [dot] com>
+# Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Contributor: Ionut Biru <ibiru@archlinux.org>
set -u
-_pkgname='libgxps'
-pkgname='libgxps-git'
-pkgver=0.3.0.r0.g762b302
+pkgname=libgxps
+pkgname+='-git'
+pkgver=0.3.2.r6.g665dc29
pkgrel=1
-pkgdesc='An XPS Documents library'
-arch=('i686' 'x86_64')
-url="https://git.gnome.org/browse/${_pkgname}/"
-license=('GPL')
-depends=('gtk3' 'libarchive' 'libjpeg-turbo' 'libtiff' 'lcms2' 'glib2' 'openssl-1.0')
-makedepends=('gobject-introspection' 'gtk-doc' 'git' 'meson' 'gnome-common')
-provides=("${_pkgname}=${pkgver%.r*}")
-conflicts=("${_pkgname}")
-_verwatch=("${url}" "/browse/${_pkgname}/snapshot/${_pkgname}-\([0-9\.]\+\)\.tar\.xz" 'l')
-source=("git://git.gnome.org/${_pkgname}")
+pkgdesc="XPS Documents library"
+url="https://wiki.gnome.org/Projects/libgxps"
+arch=(x86_64)
+arch+=('i686')
+license=(GPL2)
+depends=(
+ cairo
+ freetype2
+ glib2
+ lcms2
+ libarchive
+ libjpeg-turbo
+ libpng
+ libtiff
+)
+makedepends=(
+ git
+ gobject-introspection
+ gtk-doc
+ gtk3
+ meson
+)
+provides=("${pkgname%-git}=${pkgver%.r*}")
+conflicts=("${pkgname%-git}")
+#_verwatch=("${url}" "/browse/${_pkgname}/snapshot/${_pkgname}-\([0-9\.]\+\)\.tar\.xz" 'l')
+_srcdir="${pkgname%-git}"
+source=("git+https://gitlab.gnome.org/GNOME/libgxps.git")
+md5sums=('SKIP')
sha256sums=('SKIP')
+b2sums=('SKIP')
pkgver() {
set -u
- cd "${_pkgname}"
- git describe --tags --long | sed -E -e 's/([^-]*-g)/r\1/;s/-/./g;s/v//'
+ cd "${_srcdir}"
+ git describe --tags --long | sed -E -e 's/([^-]*-g)/r\1/' -e 's/-/./g' #-e 's/v//'
set +u
}
prepare() {
set -u
- mkdir 'build'
- cd "${_pkgname}"
+ cd "${_srcdir}"
set +u
}
build() {
set -u
- cd 'build'
- if [ ! -s 'config.h' ]; then
- meson --prefix='/usr' --buildtype='release' "../${_pkgname}" -Denable-gtk-doc='true' -Denable-man='true'
- fi
- ninja
+ local meson_options=(
+ -D enable-man=true
+ -D enable-gtk-doc=true
+ )
+
+ arch-meson libgxps build "${meson_options[@]}"
+ meson compile -C build
set +u
}
check() {
set -u
- cd 'build'
- meson test
+ meson test -C build --print-errorlogs
set +u
}
package() {
set -u
- cd 'build'
- DESTDIR="${pkgdir}" ninja install
+ meson install -C build --destdir "$pkgdir"
set +u
}
set +u
+
+# vim:set sw=2 sts=-1 et: