summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD88
2 files changed, 71 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 781c858ff997..bc188f40946f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,29 @@
-# Generated by mksrcinfo v8
-# Sat Mar 4 19:31:03 UTC 2017
pkgbase = libgxps-git
- pkgdesc = An XPS Documents library
- pkgver = 0.2.5.r0.gac54305
+ pkgdesc = XPS Documents library
+ pkgver = 0.3.2.r6.g665dc29
pkgrel = 1
- url = https://git.gnome.org/browse/libgxps/
- arch = i686
+ url = https://wiki.gnome.org/Projects/libgxps
arch = x86_64
- license = GPL
+ arch = i686
+ license = GPL2
makedepends = git
- makedepends = gnome-common
- makedepends = gtk-doc
makedepends = gobject-introspection
+ makedepends = gtk-doc
+ makedepends = gtk3
+ makedepends = meson
depends = cairo
+ depends = freetype2
+ depends = glib2
+ depends = lcms2
depends = libarchive
+ depends = libjpeg-turbo
+ depends = libpng
depends = libtiff
- provides = libgxps=0.2.5
+ provides = libgxps=0.3.2
conflicts = libgxps
- source = git://git.gnome.org/libgxps
+ source = git+https://gitlab.gnome.org/GNOME/libgxps.git
+ md5sums = SKIP
sha256sums = SKIP
+ b2sums = SKIP
pkgname = libgxps-git
-
diff --git a/PKGBUILD b/PKGBUILD
index eaf31c3b63fb..d3996b30d370 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,60 +1,80 @@
# Maintainer: Chris Severance aur.severach AatT spamgourmet.com
-# Contributor: Auguste Pop <auguste [at] gmail [dot] com>
+# Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Contributor: Ionut Biru <ibiru@archlinux.org>
set -u
-_pkgname='libgxps'
-pkgname='libgxps-git'
-pkgver=0.2.5.r0.gac54305
+pkgname=libgxps
+pkgname+='-git'
+pkgver=0.3.2.r6.g665dc29
pkgrel=1
-pkgdesc='An XPS Documents library'
-arch=('i686' 'x86_64')
-url="https://git.gnome.org/browse/${_pkgname}/"
-license=('GPL')
-depends=('cairo' 'libarchive' 'libtiff')
-makedepends=('git' 'gnome-common' 'gtk-doc' 'gobject-introspection')
-provides=("${_pkgname}=${pkgver%.r*}")
-conflicts=("${_pkgname}")
-_verwatch=("${url}" "/browse/${_pkgname}/snapshot/${_pkgname}-\([0-9\.]\+\)\.tar\.xz" 'l')
-source=("git://git.gnome.org/${_pkgname}")
+pkgdesc="XPS Documents library"
+url="https://wiki.gnome.org/Projects/libgxps"
+arch=(x86_64)
+arch+=('i686')
+license=(GPL2)
+depends=(
+ cairo
+ freetype2
+ glib2
+ lcms2
+ libarchive
+ libjpeg-turbo
+ libpng
+ libtiff
+)
+makedepends=(
+ git
+ gobject-introspection
+ gtk-doc
+ gtk3
+ meson
+)
+provides=("${pkgname%-git}=${pkgver%.r*}")
+conflicts=("${pkgname%-git}")
+#_verwatch=("${url}" "/browse/${_pkgname}/snapshot/${_pkgname}-\([0-9\.]\+\)\.tar\.xz" 'l')
+_srcdir="${pkgname%-git}"
+source=("git+https://gitlab.gnome.org/GNOME/libgxps.git")
+md5sums=('SKIP')
sha256sums=('SKIP')
+b2sums=('SKIP')
pkgver() {
set -u
- cd "${srcdir}/${_pkgname}"
- git describe --tags --long | sed -E -e 's/([^-]*-g)/r\1/;s/-/./g;s/v//'
+ cd "${_srcdir}"
+ git describe --tags --long | sed -E -e 's/([^-]*-g)/r\1/' -e 's/-/./g' #-e 's/v//'
set +u
}
prepare() {
set -u
- cd "${srcdir}/${_pkgname}"
- ./autogen.sh --prefix='/usr'
- ./configure --prefix='/usr' --disable-test
+ cd "${_srcdir}"
set +u
}
build() {
set -u
- cd "${srcdir}/${_pkgname}"
- make -s -j $(nproc)
+ local meson_options=(
+ -D enable-man=true
+ -D enable-gtk-doc=true
+ )
+
+ arch-meson libgxps build "${meson_options[@]}"
+ meson compile -C build
+ set +u
+}
+
+check() {
+ set -u
+ meson test -C build --print-errorlogs
set +u
}
package() {
set -u
- cd "${srcdir}/${_pkgname}"
- make DESTDIR="${pkgdir}/" install # This generates some /usr/lib errors
+ meson install -C build --destdir "$pkgdir"
set +u
- # Ensure there are no forbidden paths. Place at the end of package() and comment out as you find or need exceptions. (git-aurcheck)
- ! test -d "${pkgdir}/bin" || { echo "Line ${LINENO} Forbidden: /bin"; false; }
- ! test -d "${pkgdir}/sbin" || { echo "Line ${LINENO} Forbidden: /sbin"; false; }
- ! test -d "${pkgdir}/lib" || { echo "Line ${LINENO} Forbidden: /lib"; false; }
- ! test -d "${pkgdir}/share" || { echo "Line ${LINENO} Forbidden: /share"; false; }
- ! test -d "${pkgdir}/usr/sbin" || { echo "Line ${LINENO} Forbidden: /usr/sbin"; false; }
- ! test -d "${pkgdir}/usr/local" || { echo "Line ${LINENO} Forbidden: /usr/local"; false; }
- ! grep -lr "/sbin" "${pkgdir}" || { echo "Line ${LINENO} Forbidden: /sbin"; false; }
- ! grep -lr "/usr/tmp" "${pkgdir}" || { echo "Line ${LINENO} Forbidden: /usr/tmp"; false; }
- ! grep -lr "/usr/local" "${pkgdir}" || { echo "Line ${LINENO} Forbidden: /usr/local"; false; }
- ! pcre2grep -Ilr "(?<!/usr)/bin" "${pkgdir}" || { echo "Line ${LINENO} Forbidden: /bin"; false; }
}
set +u
+
+# vim:set sw=2 sts=-1 et: