summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD33
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..abf05566b2f3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = libhangul-git
+ pkgdesc = A library to support hangul input method logic
+ pkgver = 0.1.0.r51.2ddc547f014a
+ pkgrel = 1
+ url = https://github.com/libhangul/libhangul
+ arch = x86_64
+ license = LGPL-2.1
+ makedepends = binutils
+ makedepends = intltool
+ makedepends = automake
+ makedepends = autoconf
+ provides = libhangul
+ conflicts = libhangul
+ source = git+https://github.com/libhangul/libhangul.git
+ md5sums = SKIP
+
+pkgname = libhangul-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5408470a2c74
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/libhangul/
+/pkg/
+/src/
+*.pkg.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c31dfd9b52a4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Simon Ser
+pkgname=libhangul-git
+pkgver=0.1.0.r51.2ddc547f014a
+pkgrel=1
+pkgdesc="A library to support hangul input method logic"
+arch=('x86_64')
+url="https://github.com/libhangul/libhangul"
+license=('LGPL-2.1')
+depends=()
+makedepends=('binutils' 'intltool' 'automake' 'autoconf')
+provides=('libhangul')
+conflicts=('libhangul')
+source=("git+https://github.com/libhangul/libhangul.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd libhangul
+ printf "%s" "$(git describe --long | sed 's/libhangul-//' | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd libhangul
+ touch config.rpath
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd libhangul
+ make DESTDIR="$pkgdir/" install
+ install -D COPYING "$pkgdir/usr/share/licenses/libhangul/COPYING"
+}