summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b11a6d1544cf..3c6718f79ad7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libidn2-git
pkgdesc = An implementation of IDNA 2008 and TR46
- pkgver = 2.3.0.r26.g985686b
+ pkgver = 2.3.4.r3.gecdf251
pkgrel = 1
url = https://www.gnu.org/software/libidn/#libidn2
arch = i686
@@ -15,7 +15,7 @@ pkgbase = libidn2-git
makedepends = ruby-ronn
depends = glibc
depends = libunistring
- provides = libidn2
+ provides = libidn2=2.3.4.r3.gecdf251
provides = libidn2.so
conflicts = libidn2
options = staticlibs
@@ -23,4 +23,3 @@ pkgbase = libidn2-git
sha256sums = SKIP
pkgname = libidn2-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 1cd13e50551a..68a0fa7ee7b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=libidn2-git
-pkgver=2.3.0.r26.g985686b
+pkgver=2.3.4.r3.gecdf251
pkgrel=1
pkgdesc="An implementation of IDNA 2008 and TR46"
arch=('i686' 'x86_64')
@@ -9,7 +9,7 @@ url="https://www.gnu.org/software/libidn/#libidn2"
license=('GPL' 'LGPL')
depends=('glibc' 'libunistring')
makedepends=('git' 'gengetopt' 'rsync' 'wget' 'gtk-doc' 'ruby-ronn')
-provides=('libidn2' 'libidn2.so')
+provides=("libidn2=$pkgver" 'libidn2.so')
conflicts=('libidn2')
options=('staticlibs')
source=("git+https://gitlab.com/libidn/libidn2.git")
@@ -19,7 +19,10 @@ sha256sums=('SKIP')
pkgver() {
cd "libidn2"
- git describe --long --tags | sed 's/^libidn2.//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ _tag=$(git tag -l --sort -v:refname | grep -E '^v?[0-9\.]+$' | head -n1)
+ _rev=$(git rev-list --count $_tag..HEAD)
+ _hash=$(git rev-parse --short HEAD)
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/^v//'
}
build() {