summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD2
-rw-r--r--install.sh29
3 files changed, 23 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 57af58ee72ae..2cc75a43b895 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Aug 16 06:56:22 UTC 2016
+# Tue Aug 16 22:36:56 UTC 2016
pkgbase = libinput-gestures
pkgdesc = Actions gestures on your touchpad using libinput
- pkgver = 2.1
+ pkgver = 2.2
pkgrel = 1
url = https://github.com/bulletmark/libinput-gestures
install = install.sh
@@ -15,7 +15,7 @@ pkgbase = libinput-gestures
conflicts = libinput-gestures-git
replaces = libinput-gestures-git
backup = etc/libinput-gestures.conf
- source = libinput-gestures-2.1::git+https://github.com/bulletmark/libinput-gestures#tag=2.1
+ source = libinput-gestures-2.2::git+https://github.com/bulletmark/libinput-gestures#tag=2.2
md5sums = SKIP
pkgname = libinput-gestures
diff --git a/PKGBUILD b/PKGBUILD
index 5251c0f506e6..667aca93e69d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: mark.blakeney at bullet-systems dot net
pkgname=libinput-gestures
-pkgver=2.1
+pkgver=2.2
pkgrel=1
pkgdesc="Actions gestures on your touchpad using libinput"
url="https://github.com/bulletmark/$pkgname"
diff --git a/install.sh b/install.sh
index 71d92d107bb3..b9085cdbf21e 100644
--- a/install.sh
+++ b/install.sh
@@ -2,16 +2,25 @@ _pkgname=libinput-gestures
post_install() {
echo -ne "\e[34;1m"
- echo -e "=== INSTALLATION NOTES for $_pkgname ==="
+ echo "=== INSTALLATION NOTES for $_pkgname ==="
echo -ne "\e[39;1m"
- echo -e "You must be a member of the input group, i.e.run:"
- echo -e " sudo gpasswd -a \$USER input"
- echo -e "Start $_pkgname from DE, or run:"
- echo -e " $_pkgname-setup start"
- echo -e "To enable auto start of $_pkgname run:"
- echo -e " $_pkgname-setup autostart"
- echo -e "Configuration files are at:"
- echo -e " /etc/$_pkgname.conf (system wide default)"
- echo -e " \$HOME/.config/$_pkgname.conf (optional per user)"
+ echo "A user must be a member of the input group, i.e. run:"
+ echo " sudo gpasswd -a \$USER input"
+ echo "A user can start $_pkgname from their DE, or run:"
+ echo " $_pkgname-setup start"
+ echo "A user can enable auto start of $_pkgname, i.e. run:"
+ echo " $_pkgname-setup autostart"
+ echo "Configuration files are at:"
+ echo " /etc/$_pkgname.conf (system wide default)"
+ echo " \$HOME/.config/$_pkgname.conf (optional per user)"
+ echo -ne "\e[0m"
+}
+
+post_upgrade() {
+ echo -ne "\e[34;1m"
+ echo "=== UPGRADE NOTES for $_pkgname ==="
+ echo -ne "\e[39;1m"
+ echo "A user should restart $_pkgname, i.e. run:"
+ echo " $_pkgname-setup restart"
echo -ne "\e[0m"
}