summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore3
-rw-r--r--Makefile19
-rw-r--r--PKGBUILD48
-rw-r--r--install.sh17
-rw-r--r--libinput-gestures.install5
6 files changed, 68 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 076f8f9a9bf1..142133908a2d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,22 @@
+# Generated by mksrcinfo v8
+# Mon Aug 15 03:31:24 UTC 2016
pkgbase = libinput-gestures
pkgdesc = Actions gestures on your touchpad using libinput
- pkgver = r543.53bd344
+ pkgver = 2.0
pkgrel = 1
url = https://github.com/bulletmark/libinput-gestures
- install = libinput-gestures.install
+ install = install.sh
arch = any
license = GPL3
+ makedepends = git
+ depends = python
depends = libinput
depends = xdotool
- depends = python
- source = libinput-gestures-r543.53bd344.tar.gz::https://github.com/bulletmark/libinput-gestures/archive/db6b6882d2d16022eba58a1a68cd701ccdd2047f.tar.gz
- md5sums = bd02814350a1aae4e65e9168dbcf658b
+ conflicts = libinput-gestures-git
+ replaces = libinput-gestures-git
+ backup = etc/libinput-gestures.conf
+ source = libinput-gestures-2.0::git+https://github.com/bulletmark/libinput-gestures#tag=2.0
+ md5sums = SKIP
pkgname = libinput-gestures
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f0428e215ceb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+libinput-gestures-*
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..573848147e93
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,19 @@
+nam = libinput-gestures
+src = PKGBUILD
+inf = .SRCINFO
+
+all: $(inf) sum check
+
+$(inf): $(src)
+ mksrcinfo
+
+check: $(src)
+ namcap $^
+
+sum: $(src)
+ updpkgsums
+
+clean:
+ rm -rf $(inf) $(nam)-* *.tar.xz *.tar.gz pkg/ src/
+
+# vim: se ts=4:
diff --git a/PKGBUILD b/PKGBUILD
index 93339f2d0510..59bce04480c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,23 @@
-# Maintainer: Gordian Edenhofer <gordian.edenhofer@gmail.com>
-
+# Maintainer: mark.blakeney at bullet-systems dot net
pkgname=libinput-gestures
-pkgver=r543.53bd344
-_commit=db6b6882d2d16022eba58a1a68cd701ccdd2047f
+pkgver=2.0
pkgrel=1
pkgdesc="Actions gestures on your touchpad using libinput"
-arch=('any')
-license=('GPL3')
-url="https://github.com/bulletmark/libinput-gestures"
-depends=('libinput' 'xdotool' 'python')
-install="${pkgname}.install"
-source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/bulletmark/libinput-gestures/archive/${_commit}.tar.gz")
-md5sums=('bd02814350a1aae4e65e9168dbcf658b')
-
-#pkgver() {
-# cd "${srcdir}/${pkgname}-${_commit}"
-# ( set -o pipefail
-# git describe --long 2>/dev/null | sed 's/^slurm-//;s/\([^-]*-g\)/r\1/;s/-/./g' \
-# || printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-# )
-#}
-
-prepare() {
- cd "${srcdir}/${pkgname}-${_commit}"
-
- # Quick and dirty fix to make /etc/conf.d/libinput-gestures.conf the main/only configuration file
- sed -i 's/~\/.config/\/etc\/conf.d/g' libinput-gestures
-}
+url="https://github.com/bulletmark/$pkgname"
+license=("GPL3")
+arch=("any")
+depends=("python" "libinput" "xdotool")
+makedepends=("git")
+conflicts=("$pkgname-git")
+replaces=("$pkgname-git")
+backup=("etc/$pkgname.conf")
+source=("$pkgname-$pkgver::git+$url#tag=$pkgver")
+install=install.sh
+md5sums=('SKIP')
package() {
- cd "${srcdir}/${pkgname}-${_commit}"
-
- install -D -m755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
- install -D -m644 "${pkgname}.conf" "${pkgdir}/etc/conf.d/${pkgname}.conf"
- install -D -m644 "${pkgname}.desktop" "${pkgdir}/etc/xdg/autostart/${pkgname}.desktop"
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
}
+
+# vim:set ts=2 sw=2 et:
diff --git a/install.sh b/install.sh
new file mode 100644
index 000000000000..71d92d107bb3
--- /dev/null
+++ b/install.sh
@@ -0,0 +1,17 @@
+_pkgname=libinput-gestures
+
+post_install() {
+ echo -ne "\e[34;1m"
+ echo -e "=== INSTALLATION NOTES for $_pkgname ==="
+ echo -ne "\e[39;1m"
+ echo -e "You must be a member of the input group, i.e.run:"
+ echo -e " sudo gpasswd -a \$USER input"
+ echo -e "Start $_pkgname from DE, or run:"
+ echo -e " $_pkgname-setup start"
+ echo -e "To enable auto start of $_pkgname run:"
+ echo -e " $_pkgname-setup autostart"
+ echo -e "Configuration files are at:"
+ echo -e " /etc/$_pkgname.conf (system wide default)"
+ echo -e " \$HOME/.config/$_pkgname.conf (optional per user)"
+ echo -ne "\e[0m"
+}
diff --git a/libinput-gestures.install b/libinput-gestures.install
deleted file mode 100644
index fb21d9a4ed9c..000000000000
--- a/libinput-gestures.install
+++ /dev/null
@@ -1,5 +0,0 @@
-post_install() {
- echo -e "\e[34;1m==>\e[39;1m NOTE: You must be a member of the input group to have permission to read the touchpad device! \e[0m"
- echo -e "\e[34;1m==>\e[39;1m NOTE: You must logout and back in order for the daemon to automatically start. \e[0m"
- echo -e "\e[34;1m==>\e[39;1m NOTE: The only honored configuration file is located at /etc/conf.d/libinput-gestures.conf . \e[0m"
-}