summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 19 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9e329398c339..fa1c08683595 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Thu Sep 19 13:34:45 UTC 2019
pkgbase = libinputsynth-git
pkgdesc = Synthesize desktop input for X11 and Wayland
- pkgver = 0.13.0.58.699426a
+ pkgver = 0.16.0.r75.f369bcf
pkgrel = 1
url = https://gitlab.freedesktop.org/xrdesktop/libinputsynth
arch = i686
@@ -10,14 +8,16 @@ pkgbase = libinputsynth-git
license = MIT
makedepends = meson
makedepends = git
- makedepends = xdotool
depends = glib2
- provides = libinputsynth=0.13.0.58.699426a
+ depends = glibc
+ depends = libx11
+ depends = libxi
+ depends = libxtst
+ depends = xdotool
+ depends = gcc-libs
+ provides = libinputsynth=0.16.0.r75.f369bcf
conflicts = libinputsynth
- options = debug
- options = !strip
source = git+https://gitlab.freedesktop.org/xrdesktop/libinputsynth.git
md5sums = SKIP
pkgname = libinputsynth-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 46bf63decc17..854c8c96b15d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,18 @@
_realname='libinputsynth'
pkgname="$_realname-git"
-pkgver=0.13.0.58.699426a
+pkgver=0.16.0.r75.f369bcf
pkgrel=1
pkgdesc='Synthesize desktop input for X11 and Wayland'
arch=('i686' 'x86_64')
url='https://gitlab.freedesktop.org/xrdesktop/libinputsynth'
-depends=('glib2')
+depends=('glib2' 'glibc' 'libx11' 'libxi' 'libxtst' 'xdotool' 'gcc-libs')
provides=("$_realname="$pkgver)
conflicts=("$_realname")
-makedepends=('meson' 'git' 'xdotool')
+makedepends=('meson' 'git')
license=('MIT')
-options=('debug' '!strip')
-
+# options=('debug' '!strip')
source=('git+https://gitlab.freedesktop.org/xrdesktop/libinputsynth.git')
-
md5sums=('SKIP')
ver() {
@@ -24,20 +22,20 @@ ver() {
}
pkgver() {
- cd $_realname
- hash=$(git log --pretty=format:'%h' -n 1)
- revision=$(git rev-list --count HEAD)
- echo $(ver).$revision.$hash
+ cd "$_realname"
+ printf "$(ver).r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
}
build() {
- cd $_realname
+ cd "$_realname"
rm -rf build
- meson build --prefix=/usr/ --libdir=lib
+ meson setup build --prefix=/usr/ --libdir=lib
ninja -C build
}
package() {
- cd $_realname
+ cd "$_realname"
DESTDIR="$pkgdir" ninja -C build install
+
+ install -Dm644 "${srcdir}"/libinputsynth/LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
}