summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD43
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f3cdc6855793
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Tue Jul 30 15:37:13 UTC 2019
+pkgbase = libinputsynth-git
+ pkgdesc = Synthesize desktop input for X11 and Wayland
+ pkgver = 0.12.1.52.98af062
+ pkgrel = 1
+ url = https://gitlab.freedesktop.org/xrdesktop/libinputsynth
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = glib2
+ provides = libinputsynth=0.12.1.52.98af062
+ conflicts = libinputsynth
+ options = debug
+ options = !strip
+ source = git+https://gitlab.freedesktop.org/xrdesktop/libinputsynth.git
+ md5sums = SKIP
+
+pkgname = libinputsynth-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d8ea0f31fc92
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Christoph Haag <christoph.haag@collabora.com>
+
+_realname='libinputsynth'
+pkgname="$_realname-git"
+pkgver=0.12.1.52.98af062
+pkgrel=1
+pkgdesc='Synthesize desktop input for X11 and Wayland'
+arch=('i686' 'x86_64')
+url='https://gitlab.freedesktop.org/xrdesktop/libinputsynth'
+depends=('glib2')
+provides=("$_realname="$pkgver)
+conflicts=("$_realname")
+makedepend=('meson' 'git')
+license=('MIT')
+options=('debug' '!strip')
+
+source=('git+https://gitlab.freedesktop.org/xrdesktop/libinputsynth.git')
+
+md5sums=('SKIP')
+
+ver() {
+ PREFIX="project('libinputsynth', 'c', version: '"
+ echo $(grep "$PREFIX" meson.build | sed -e "s/${PREFIX}//" | sed "s/',//")
+}
+
+pkgver() {
+ cd $_realname
+ hash=$(git log --pretty=format:'%h' -n 1)
+ revision=$(git rev-list --count HEAD)
+ echo $(ver).$revision.$hash
+}
+
+build() {
+ cd $_realname
+ rm -rf build
+ meson build --prefix=/usr/ --libdir=lib
+ ninja -C build
+}
+
+package() {
+ cd $_realname
+ DESTDIR="$pkgdir" ninja -C build install
+}