summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD55
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..958a7f5fa5c6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = libinstpatch
+ pkgdesc = Instrument patch library
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = http://swamiproject.org
+ arch = x86_64
+ arch = i386
+ license = LGPLv2
+ makedepends = cmake
+ makedepends = python3
+ source = https://download.savannah.gnu.org/releases/gsequencer/1.4.x/libinstpatch-1.0.0+svn386.tar.bz2
+ md5sums = 3e90da59e1d088ff9dbb270a1349cd99
+
+pkgname = libinstpatch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..54fbbc8ed1ab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=libinstpatch
+pkgver=1.0.0
+pkgsvnver=+svn386
+pkgrel=1
+epoch=
+pkgdesc="Instrument patch library"
+arch=('x86_64' 'i386')
+url="http://swamiproject.org"
+license=('LGPLv2')
+groups=()
+depends=()
+makedepends=('cmake' 'python3')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://download.savannah.gnu.org/releases/gsequencer/1.4.x/$pkgname-$pkgver$pkgsvnver.tar.bz2")
+noextract=()
+md5sums=('3e90da59e1d088ff9dbb270a1349cd99')
+validpgpkeys=()
+
+prepare() {
+ cd "$pkgname-$pkgver"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ mkdir build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ cd build
+# make -k check
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ cd build
+ make DESTDIR="$pkgdir/" install
+}