summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore27
-rw-r--r--.gitignore_append1
-rw-r--r--PKGBUILD16
4 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ec37e39cc739
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = libirecovery3
+ pkgdesc = Compatibility symlinks for libirecovery.so.3
+ pkgver = 1
+ pkgrel = 1
+ url = https://www.libimobiledevice.org/
+ arch = any
+ license = LGPL2.1
+ depends = libirecovery
+
+pkgname = libirecovery3
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f12030797c07
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,27 @@
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+*~
+
+# temporary files which can be created if a process still has a handle open of a deleted file
+.fuse_hidden*
+
+# KDE directory preferences
+.directory
+
+# Linux trash folder which might appear on any partition or disk
+.Trash-*
+
+# .nfs files are created when an open file is removed but is still being accessed
+.nfs*
+# archlinuxpackages linux
diff --git a/.gitignore_append b/.gitignore_append
new file mode 100644
index 000000000000..a92184e5a9bf
--- /dev/null
+++ b/.gitignore_append
@@ -0,0 +1 @@
+# archlinuxpackages linux
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c5b9ba2f47de
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+# Maintainer: 0x9fff00 <0x9fff00+git@protonmail.ch>
+
+pkgname=libirecovery3
+pkgver=1
+pkgrel=1
+pkgdesc="Compatibility symlinks for libirecovery.so.3"
+arch=('any')
+url="https://www.libimobiledevice.org/"
+license=('LGPL2.1')
+depends=('libirecovery')
+
+package() {
+ mkdir -p "$pkgdir/usr/lib"
+ ln -s libirecovery-1.0.so.3 "$pkgdir/usr/lib/libirecovery.so.3"
+ ln -s libirecovery-1.0.so.3.0.0 "$pkgdir/usr/lib/libirecovery.so.3.0.0"
+}