summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--ChangeLog26
-rw-r--r--PKGBUILD41
-rw-r--r--libjson-rpc-cpp.install11
4 files changed, 101 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9fadd1c3ea82
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by makepkg 4.2.0
+# Wed Jan 21 19:16:53 UTC 2015
+pkgbase = libjson-rpc-cpp
+ pkgdesc = C++ framework for json-rpc 1.0 and 2.0
+ pkgver = 0.5.0
+ pkgrel = 1
+ url = https://github.com/cinemast/libjson-rpc-cpp
+ install = libjson-rpc-cpp.install
+ changelog = ChangeLog
+ arch = i686
+ arch = x86_64
+ license = MIT
+ checkdepends = boost
+ makedepends = cmake
+ depends = curl
+ depends = argtable
+ depends = jsoncpp
+ depends = libmicrohttpd
+ source = https://github.com/cinemast/libjson-rpc-cpp/archive/v0.5.0.tar.gz
+ sha256sums = e6d8d6c20517bb38eba9dba7f372e0a95432c4cbf55ec9b136ba841faa0a6d99
+
+pkgname = libjson-rpc-cpp
+
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 000000000000..c6b38d0f987a
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,26 @@
+2015-04-07 Peter Spiess-Knafl <psk@autistici.org>
+
+ * 0.5.0-1:
+ New upstream release
+
+2015-02-10 Peter Spiess-Knafl <psk@autistici.org>
+
+ * 0.4.2-2 :
+ Removing patch to fix boost error
+
+2015-01-21 Peter Spiess-Knafl <psk@autistici.org>
+
+ * 0.4.1-1 :
+ Updated to new upstream release.
+ Fix build error with new libjsoncpp 0.7.x
+
+2014-11-21 Peter Spiess-Knafl <psk@autistici.org>
+
+ * 0.4-1 :
+ Updated to new upstream release.
+ See at changelog: https://github.com/cinemast/libjson-rpc-cpp/blob/master/CHANGELOG.md
+
+2014-11-04 Peter Spiess-Knafl <psk@autistici.org>
+
+ * 0.3.2-1 :
+ Initial release and replacement of libjsonrpc-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..073f8a28b120
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Peter Spiess-Knafl <psk@autistici.org>
+# Contributor: Daniel Bomar <dbdaniel42@gmail.com>
+pkgname=libjson-rpc-cpp
+pkgver=0.5.0
+pkgrel=1
+pkgdesc="C++ framework for json-rpc 1.0 and 2.0"
+arch=('i686' 'x86_64')
+url="https://github.com/cinemast/libjson-rpc-cpp"
+license=('MIT')
+depends=('curl' 'argtable' 'jsoncpp' 'libmicrohttpd')
+makedepends=('cmake')
+checkdepends=('boost')
+install=libjson-rpc-cpp.install
+changelog=ChangeLog
+source=('https://github.com/cinemast/libjson-rpc-cpp/archive/v0.5.0.tar.gz')
+sha256sums=('e6d8d6c20517bb38eba9dba7f372e0a95432c4cbf55ec9b136ba841faa0a6d99')
+
+build() {
+ msg2 "Creating build directories"
+ mkdir -p $pkgname-$pkgver/build
+ cd $pkgname-$pkgver/build
+ msg2 "Invoking cmake"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DBUILD_STATIC_LIBS=TRUE ..
+ msg2 "Building the framework"
+ make
+}
+
+check() {
+ cd $pkgname-$pkgver/build
+ msg2 "Running unit tests"
+ make test
+}
+
+package() {
+ cd $pkgname-$pkgver/build
+ msg2 "Packing all together"
+ make DESTDIR="${pkgdir}" install
+ msg2 "Add MIT License to package"
+ install -D -m644 "${srcdir}/$pkgname-$pkgver/LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
diff --git a/libjson-rpc-cpp.install b/libjson-rpc-cpp.install
new file mode 100644
index 000000000000..addf5b1608ec
--- /dev/null
+++ b/libjson-rpc-cpp.install
@@ -0,0 +1,11 @@
+post_install () {
+ ldconfig
+}
+
+post_upgrade () {
+ ldconfig
+}
+
+post_remove () {
+ ldconfig
+}