summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD18
2 files changed, 19 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d71d9c17ea82..c9e637975f00 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = liblbfgs
pkgdesc = A C port of the implementation of Limited-memory Broyden-Fletcher-Goldfarb-Shanno (L-BFGS) method written by Jorge Nocedal.
pkgver = 1.10
- pkgrel = 1
+ pkgrel = 2
url = http://www.chokkan.org/software/liblbfgs/
arch = i686
arch = x86_64
license = custom:MIT
- source = https://github.com/downloads/chokkan/liblbfgs/liblbfgs-1.10.tar.gz
- md5sums = 2a46da6c4014d6b1e8a8790a93edffbb
+ makedepends = autoconf-archive
+ makedepends = libtool
+ source = https://github.com/chokkan/liblbfgs/archive/refs/tags/v1.10.tar.gz
+ sha512sums = 2b08dc5d4fdd737575f58983fa7b6c143bc12edaca47b7aeadf221afe6e573fa4a53423f323f569aa93c9dbeafb9b80a6d2f755fec6da04e6b7221f0a67816f8
pkgname = liblbfgs
-
diff --git a/PKGBUILD b/PKGBUILD
index 9ff4dedc951b..c9ba6f98462c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,28 @@
-# Maintainer: Tavian Barnes <tavianator@tavianator.com>
+# Maintainer: danieltetraquark
+# Contributor: Tavian Barnes <tavianator@tavianator.com>
# Contributor: ngukho <ngukho at gmail dot com>
pkgname=liblbfgs
pkgver=1.10
-pkgrel=1
+pkgrel=2
pkgdesc="A C port of the implementation of Limited-memory Broyden-Fletcher-Goldfarb-Shanno (L-BFGS) method written by Jorge Nocedal."
arch=('i686' 'x86_64')
url="http://www.chokkan.org/software/liblbfgs/"
+makedepends=('autoconf-archive' 'libtool')
license=('custom:MIT')
-source=("https://github.com/downloads/chokkan/liblbfgs/$pkgname-$pkgver.tar.gz")
-md5sums=('2a46da6c4014d6b1e8a8790a93edffbb') #generate with 'makepkg -g'
+source=("https://github.com/chokkan/liblbfgs/archive/refs/tags/v$pkgver.tar.gz")
+sha512sums=('2b08dc5d4fdd737575f58983fa7b6c143bc12edaca47b7aeadf221afe6e573fa4a53423f323f569aa93c9dbeafb9b80a6d2f755fec6da04e6b7221f0a67816f8')
build() {
cd "$srcdir/$pkgname-$pkgver"
+ # note: Original tar gz contained the generated files for ./configure, but it is only available from webarchive, so we can simply regenerate them.
+ # URL for historical tar gz file https://web.archive.org/web/20140815101758if_/https://cloud.github.com/downloads/chokkan/liblbfgs/liblbfgs-1.10.tar.gz
+ autoupdate
+ libtoolize --force
+ aclocal
+ autoheader
+ automake --force-missing --add-missing
+ autoconf
./configure --prefix=/usr
make
}