summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD52
2 files changed, 30 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8103d5ded6a1..dd03b25827c7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = libliftoff-git
- pkgdesc = Lightweight KMS plane library
- pkgver = v0.1.0.r0.ga58b638736ad5efe
+ pkgdesc = Lightweight KMS plane library (git development version)
+ pkgver = 0.4.0.r11.g29a06ad
pkgrel = 1
- url = https://github.com/emersion/libliftoff
+ url = https://gitlab.freedesktop.org/emersion/libliftoff
arch = x86_64
- license = custom:MIT
+ license = MIT
makedepends = git
makedepends = meson
makedepends = ninja
depends = libdrm
+ depends = glibc
provides = libliftoff
conflicts = libliftoff
- source = libliftoff-git::git+https://github.com/emersion/libliftoff.git
- sha512sums = SKIP
+ source = libliftoff-git::git+https://gitlab.freedesktop.org/emersion/libliftoff.git
+ b2sums = SKIP
pkgname = libliftoff-git
diff --git a/PKGBUILD b/PKGBUILD
index 948c0709d86c..db0383ee42be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,36 @@
-# Maintainer: Sefa Eyeoglu <contact@scrumplex.net>
-
+# Maintainer: GreyXor <greyxor@protonmail.com>
pkgname=libliftoff-git
-pkgver=v0.1.0.r0.ga58b638736ad5efe
+pkgver=0.4.0.r11.g29a06ad
pkgrel=1
-pkgdesc="Lightweight KMS plane library"
-arch=(x86_64)
-url="https://github.com/emersion/libliftoff"
-license=("custom:MIT")
-depends=("libdrm")
-makedepends=("git" "meson" "ninja")
-provides=("libliftoff")
-conflicts=("libliftoff")
-source=("$pkgname::git+https://github.com/emersion/libliftoff.git")
-sha512sums=('SKIP')
-
+pkgdesc="Lightweight KMS plane library (git development version)"
+arch=('x86_64')
+url="https://gitlab.freedesktop.org/emersion/libliftoff"
+license=("MIT")
+depends=("libdrm"
+"glibc")
+makedepends=("git"
+"meson"
+"ninja"
+)
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("${pkgname}::git+${url}.git")
+b2sums=('SKIP')
pkgver() {
- cd "$pkgname"
+ cd "$pkgname"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
-
- meson --prefix /usr --buildtype=release "$pkgname" build
- ninja -C build
-}
-
-check() {
-
- ninja -C build test
+ arch-meson "$pkgname" build
+ meson compile -C build
}
package() {
- DESTDIR="$pkgdir" ninja -C build install
-
- cd "$srcdir/$pkgname"
+ meson install -C build --destdir "$pkgdir"
- install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm644 "README.md" "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+ install -Dm644 "${pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 "${pkgname}/README.md" "${pkgdir}/usr/share/doc/${pkgname}/README.md"
}