summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4b8d7f0947d..af1b43fb0855 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = libmfile-git
pkgdesc = Library for compressed storage of spectroscopy data in nuclear physics
pkgver = r57.a18a066
- pkgrel = 1
+ pkgrel = 2
url = https://gitlab.ikp.uni-koeln.de/jmayer/libmfile
- arch = any
+ arch = i686
+ arch = x86_64
license = BSD
makedepends = git
makedepends = cmake
+ depends = glibc
provides = libmfile
conflicts = libmfile
options = !emptydirs
diff --git a/PKGBUILD b/PKGBUILD
index 5b81122fedd6..c420e9bb4605 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,16 @@
pkgname=libmfile-git
_pkgname=libmfile
pkgver=r57.a18a066
-pkgrel=1
+pkgrel=2
pkgdesc="Library for compressed storage of spectroscopy data in nuclear physics"
-arch=('any')
+arch=('i686' 'x86_64')
url="https://gitlab.ikp.uni-koeln.de/jmayer/libmfile"
license=('BSD')
conflicts=('libmfile')
provides=('libmfile')
-makedepends=('git' 'cmake')
+depends=('glibc')
+makedepends=('git'
+ 'cmake')
options=(!emptydirs)
source=('git+https://gitlab.ikp.uni-koeln.de/jmayer/libmfile.git#branch=anniversary')
sha256sums=('SKIP')
@@ -28,4 +30,6 @@ build() {
package() {
cd "${srcdir}/${_pkgname}"
make DESTDIR=${pkgdir} install
+ mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m 0644 license.md "${pkgdir}/usr/share/licenses/${pkgname}/"
}