summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD32
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cc43e315a51a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = libmpd-git
+ pkgdesc = Signal based wrapper around libmpdclient
+ pkgver = release.0.20.0.r23.g2c8b595
+ pkgrel = 1
+ url = http://mpd.wikia.com/wiki/ClientLib:libmpd
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = glib2
+ conflicts = libmpd
+ source = libmpd-git::git://git.musicpd.org/master/libmpd.git
+ md5sums = SKIP
+
+pkgname = libmpd-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e1dfd1735b2a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+pkgname=libmpd-git
+pkgver=release.0.20.0.r23.g2c8b595
+pkgrel=1
+pkgdesc="Signal based wrapper around libmpdclient"
+arch=('i686' 'x86_64')
+url="http://mpd.wikia.com/wiki/ClientLib:libmpd"
+license=('GPL')
+depends=('glib2')
+conflicts=('libmpd')
+
+source=($pkgname::git://git.musicpd.org/master/libmpd.git)
+
+md5sums=(SKIP)
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$pkgname"
+
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname"
+ make DESTDIR="$pkgdir" install
+}
+