summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD9
-rw-r--r--include_suffix.patch11
3 files changed, 3 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2cd22c11280a..d9a9dc6c5adf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,7 +12,6 @@ pkgbase = libmygpo-qt5-git
provides = libmygpo-qt5
conflicts = libmygpo-qt5
source = git+https://github.com/gpodder/libmygpo-qt.git
- source = include_suffix.patch
sha256sums = SKIP
sha256sums = 7994f3c29086268b8138e7ac0c0d1a99acfa55e07a7695507f314903b890f79d
diff --git a/PKGBUILD b/PKGBUILD
index bc7a30257f74..953a6f13f8b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Thanks to Andrea Scarpino <andrea@archlinux.org>
pkgname=libmygpo-qt5-git
-pkgver=1.0.8.2.g7946293
+pkgver=1.0.8.3.gfd4e40a
pkgrel=1
pkgdesc="A C++/Qt client library for gpodder.net. Git and Qt5 version."
arch=('i686' 'x86_64')
@@ -10,8 +10,8 @@ url="http://wiki.gpodder.org/wiki/Libmygpo-qt"
license=('LGPL2.1')
depends=('qt5-base')
makedepends=('cmake' 'doxygen')
-source=("git+https://github.com/gpodder/libmygpo-qt.git" "include_suffix.patch")
-sha256sums=('SKIP' '7994f3c29086268b8138e7ac0c0d1a99acfa55e07a7695507f314903b890f79d')
+source=("git+https://github.com/gpodder/libmygpo-qt.git")
+sha256sums=('SKIP')
provides=('libmygpo-qt5')
conflicts=('libmygpo-qt5')
@@ -21,9 +21,6 @@ pkgver() {
}
prepare() {
- cd libmygpo-qt
- patch -Np0 -i "../include_suffix.patch"
- cd ../
mkdir build
}
diff --git a/include_suffix.patch b/include_suffix.patch
deleted file mode 100644
index 8f9ea7d2250e..000000000000
--- a/include_suffix.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- CMakeLists.txt 2015-06-04 15:08:42.414256487 +0200
-+++ CMakeLists.txt.patch 2015-06-04 15:08:14.510491630 +0200
-@@ -98,7 +98,7 @@
- set(LIB_SUFFIX "" CACHE STRING "The directories where to install libraries to")
- set(LIB_INSTALL_DIR lib${LIB_SUFFIX} )
- set(LIB_DIR_PKGCONF "${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}")
--set(INCLUDE_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/include/mygpo-qt" CACHE PATH "The directory the headers are installed in")
-+set(INCLUDE_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/include/mygpo-qt${MYGPO_QT_VERSION_SUFFIX}" CACHE PATH "The directory the headers are installed in")
- set(CMAKECONFIG_INSTALL_DIR ${LIB_INSTALL_DIR}/cmake/mygpo-qt )
-
- if( APPLE )