summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
-rw-r--r--acr122bug.patch28
3 files changed, 24 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fd6b85229862..91b4de03638b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libnfc-no_alternate_usb-git
pkgdesc = Platform independent Near Field Communication (NFC) library
- pkgver = 1.7.1.r223.gf8b2852
+ pkgver = 1.8.0.r41.gd9a04a5
pkgrel = 1
url = http://nfc-tools.org/
arch = i686
@@ -11,13 +11,15 @@ pkgbase = libnfc-no_alternate_usb-git
makedepends = git
depends = pcsclite
depends = libusb-compat
- provides = libnfc=1.7.1.r223.gf8b2852
+ provides = libnfc=1.8.0.r41.gd9a04a5
conflicts = libnfc
conflicts = libnfc-svn
conflicts = libnfc-git
replaces = libnfc-svn
source = git+https://github.com/nfc-tools/libnfc.git
+ source = acr122bug.patch
sha256sums = SKIP
+ sha256sums = 11645025ea9e791dd8fd308694061eac1c5003bf60dc071f33bd615cc70c385b
pkgname = libnfc-no_alternate_usb-git
diff --git a/PKGBUILD b/PKGBUILD
index 3bbc4610e3c2..0dc506542aaa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: hardfalcon <?>
_pkgname=libnfc
pkgname="${_pkgname}-no_alternate_usb-git"
-pkgver=1.7.1.r223.gf8b2852
+pkgver=1.8.0.r41.gd9a04a5
pkgrel=1
pkgdesc='Platform independent Near Field Communication (NFC) library'
arch=('i686' 'x86_64')
@@ -14,8 +14,10 @@ makedepends=('doxygen' 'zip' 'git')
provides=("libnfc=${pkgver}")
conflicts=(libnfc libnfc-svn libnfc-git)
replaces=(libnfc-svn)
-source=("git+https://github.com/nfc-tools/libnfc.git")
-sha256sums=('SKIP')
+source=("git+https://github.com/nfc-tools/libnfc.git"
+ "acr122bug.patch")
+sha256sums=('SKIP'
+ '11645025ea9e791dd8fd308694061eac1c5003bf60dc071f33bd615cc70c385b')
pkgver() {
cd "$_pkgname"
@@ -28,8 +30,7 @@ prepare() {
if [ ! -e README-Windows.txt ]; then
ln -s README-Windows.{md,txt}
fi
- ls
- patch -p1 < ../../acr122bug.patch
+ patch -p1 < "${srcdir}/acr122bug.patch"
./make_release.sh
#autoreconf -vis
./configure --prefix /usr --enable-doc --sysconfdir=/etc
diff --git a/acr122bug.patch b/acr122bug.patch
index 956c599a090d..745695c8384c 100644
--- a/acr122bug.patch
+++ b/acr122bug.patch
@@ -1,20 +1,20 @@
diff --git a/libnfc/drivers/acr122_usb.c b/libnfc/drivers/acr122_usb.c
-index a6392e8..16eddef 100644
+index 17ae5fb..bab8bc2 100644
--- a/libnfc/drivers/acr122_usb.c
+++ b/libnfc/drivers/acr122_usb.c
-@@ -427,13 +427,13 @@ acr122_usb_open(const nfc_context *context, const nfc_connstring connstring)
- goto free_mem;
- }
+@@ -434,13 +434,13 @@ acr122_usb_open(const nfc_context *context, const nfc_connstring connstring)
-- res = usb_set_altinterface(data.pudh, 0);
-+ /*res = usb_set_altinterface(data.pudh, 0);
- if (res < 0) {
- log_put(LOG_GROUP, LOG_CATEGORY, NFC_LOG_PRIORITY_ERROR, "Unable to set alternate setting on USB interface (%s)", _usb_strerror(res));
- usb_close(data.pudh);
- // we failed to use the specified device
- goto free_mem;
-- }
-+ }*/
+ // Check if there are more than 0 alternative interfaces and claim the first one
+ if (dev->config->interface->altsetting->bAlternateSetting > 0) {
+- res = usb_set_altinterface(data.pudh, 0);
++ /*res = usb_set_altinterface(data.pudh, 0);
+ if (res < 0) {
+ log_put(LOG_GROUP, LOG_CATEGORY, NFC_LOG_PRIORITY_ERROR, "Unable to set alternate setting on USB interface (%s)", _usb_strerror(res));
+ usb_close(data.pudh);
+ // we failed to use the specified device
+ goto free_mem;
+- }
++ }*/
+ }
// Allocate memory for the device info and specification, fill it and return the info
- pnd = nfc_device_new(context, connstring);