summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD47
2 files changed, 32 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c18f523d672..5b40a6ea810f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,13 @@
+# Generated by mksrcinfo v8
+# Thu Oct 13 09:39:33 UTC 2016
pkgbase = libnotify-id-git
pkgdesc = Gnome notification library, including ID patch
- pkgver = 20130129
+ pkgver = 0.7.6.7.g6b03c47
pkgrel = 1
url = http://library.gnome.org/devel/libnotify/
arch = i686
arch = x86_64
- license = GPL2.1
+ license = GPL
makedepends = pkgconfig
makedepends = git
makedepends = gobject-introspection
@@ -15,7 +17,9 @@ pkgbase = libnotify-id-git
conflicts = libnotify
conflicts = libnotify-git
options = !libtool
+ source = git://git.gnome.org/libnotify.git
source = https://launchpadlibrarian.net/105791133/print-and-replace-id-v3.patch
+ md5sums = SKIP
md5sums = f75d23de7ee23e37ac36889ece359587
pkgname = libnotify-id-git
diff --git a/PKGBUILD b/PKGBUILD
index 2c8ddcd448bd..f72c493267de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,43 @@
# Maintainer: Florian Dejonckheere <florian at floriandejonckheere dot be>
pkgname=libnotify-id-git
-pkgver=20130129
+_pkgname=libnotify
+pkgver=0.7.6.7.g6b03c47
pkgrel=1
pkgdesc="Gnome notification library, including ID patch"
arch=('i686' 'x86_64')
-license=('GPL2.1')
+license=('GPL')
url="http://library.gnome.org/devel/libnotify/"
depends=()
makedepends=('pkgconfig' 'git' 'gobject-introspection' 'gtk-doc' 'gnome-common-git')
options=('!libtool')
-conflicts=('libnotify' 'libnotify-git')
-provides=('libnotify=0.7.5')
-source=('https://launchpadlibrarian.net/105791133/print-and-replace-id-v3.patch')
-md5sums=('f75d23de7ee23e37ac36889ece359587')
+conflicts=("${_pkgname}" "${_pkgname}-git")
+provides=("${_pkgname}=0.7.5")
+source=("git://git.gnome.org/${_pkgname}.git"
+ 'https://launchpadlibrarian.net/105791133/print-and-replace-id-v3.patch')
+md5sums=('SKIP'
+ 'f75d23de7ee23e37ac36889ece359587')
-_gitroot="git://git.gnome.org/libnotify.git"
-_gitname="libnotify"
+pkgver() {
+ cd "${_pkgname}"
+ git describe --always | sed 's|-|.|g'
+}
+
+prepare() {
+ cd "${_pkgname}"
+ patch -p1 < ../../print-and-replace-id-v3.patch
+ ./autogen.sh --prefix=/usr
+}
build() {
- cd ${srcdir}
- msg "Connecting to git.gnome.org GIT server...."
+ cd "${_pkgname}"
- if [ -d ${srcdir}/$_gitname ] ; then
- cd $_gitname && git pull origin
- msg "The local files are updated."
- else
- git clone $_gitroot
- fi
+ make
+}
- cd ${srcdir}/$_gitname
- patch -p1 < ../../print-and-replace-id-v3.patch
- ./autogen.sh --prefix=/usr
- make || return 1
- make DESTDIR="$pkgdir/" install || return 1
+package() {
+ cd "${_pkgname}"
+
+ make DESTDIR="${pkgdir}" install
}