summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD33
2 files changed, 22 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b0b346a8821d..1eb6f5b128f8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = libopenaptx-git
pkgdesc = Open Source implementation of Audio Processing Technology codec (aptX)
- pkgver = 0.2.0.r1.g99b0921
+ pkgver = 0.2.1.r0.g811bc18
pkgrel = 1
url = https://github.com/pali/libopenaptx
arch = x86_64
- license = LGPL2.1
+ license = GPL3
makedepends = git
depends = glibc
- provides = libopenaptx
+ provides = libopenaptx.so
conflicts = libopenaptx
- source = git+https://github.com/pali/libopenaptx.git
- sha512sums = SKIP
+ source = libopenaptx::git+https://github.com/pali/libopenaptx
+ sha256sums = SKIP
pkgname = libopenaptx-git
-
diff --git a/PKGBUILD b/PKGBUILD
index a5d382c66aec..39240ffbb492 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,32 @@
-# Maintainer: katt <magunasu.b97@gmail.com>
-# Contributor: Mitchell Renouf <mitchellarenouf@gmail.com>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Kicker0429 <kicker0429@yahoo.com>
+# Contributor: katt <magunasu.b97@gmail.com>
pkgname=libopenaptx-git
-pkgver=0.2.0.r1.g99b0921
+_pkgname="${pkgname%-git}"
+pkgver=0.2.1.r0.g811bc18
pkgrel=1
pkgdesc='Open Source implementation of Audio Processing Technology codec (aptX)'
-arch=(x86_64)
+arch=('x86_64')
url='https://github.com/pali/libopenaptx'
-license=(LGPL2.1)
-depends=(glibc)
-makedepends=(git)
-provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}")
-source=(git+"${url}".git)
-sha512sums=(SKIP)
+license=('GPL3')
+depends=('glibc')
+makedepends=('git')
+provides=("$_pkgname.so")
+conflicts=("$_pkgname")
+source=("$_pkgname::git+$url")
+sha256sums=('SKIP')
pkgver() {
- cd "${pkgname%-git}"
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git -C "$_pkgname" describe --long --tags | sed 's/-/.r/;s/-/./'
}
build() {
- cd "${pkgname%-git}"
- make
+ cd "$_pkgname"
+ make CFLAGS="-O2 $CFLAGS" LDFLAGS="$LDFLAGS"
}
package() {
- cd "${pkgname%-git}"
+ cd "$_pkgname"
make PREFIX=/usr DESTDIR="$pkgdir" install
}