summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD28
2 files changed, 11 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 00e395d6896a..1a831d38a0b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
# Generated by mksrcinfo v8
-# Wed Oct 25 18:17:02 UTC 2017
+# Thu Apr 12 15:02:05 UTC 2018
pkgbase = libopenblas
pkgdesc = An optimized BLAS library based on GotoBLAS2 1.13 BSD
pkgver = 0.2.20
- pkgrel = 1
+ pkgrel = 2
url = http://www.openblas.net
- arch = i686
arch = x86_64
license = BSD
makedepends = perl
diff --git a/PKGBUILD b/PKGBUILD
index 913479953bc2..56263ed79476 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,45 +3,35 @@
pkgname=libopenblas
_pkgname=OpenBLAS
pkgver=0.2.20
-pkgrel=1
+pkgrel=2
pkgdesc="An optimized BLAS library based on GotoBLAS2 1.13 BSD"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url='http://www.openblas.net'
license=('BSD')
depends=('gcc-libs')
makedepends=('perl'
'gcc-fortran'
)
-options=(!emptydirs)
source=("${_pkgname}-v${pkgver}.tar.gz::http://github.com/xianyi/OpenBLAS/archive/v${pkgver}.tar.gz")
sha256sums=('5ef38b15d9c652985774869efd548b8e3e972e1e99475c673b25537ed7bcf394')
+options=('!emptydirs')
build() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "${_pkgname}-${pkgver}"
make \
- USE_OPENMP=1 \
- NO_AFFINITY=1 \
- MAJOR_VERSION=3 \
- NUM_THREADS="$(nproc)"
+ libs netlib shared
}
package() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "${_pkgname}-${pkgver}"
make \
- PREFIX="${pkgdir}/usr" \
- NUM_THREADS=$(nproc) \
- OPENBLAS_INCLUDE_DIR="${pkgdir}/usr/include/openblas" \
- MAJOR_VERSION=3 \
+ PREFIX=/usr \
+ OPENBLAS_INCLUDE_DIR="\$(PREFIX)/include/openblas" \
+ DESTDIR="${pkgdir}" \
install
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-
-
- sed -e "s|${pkgdir}||" \
- -i "${pkgdir}/usr/lib/cmake/openblas/OpenBLASConfig.cmake" \
- -i "${pkgdir}/usr/lib/pkgconfig/openblas.pc"
-
}