summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--0001-Revert-Drop-install-target-and-documentation.patch90
-rw-r--r--PKGBUILD8
3 files changed, 98 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad43db662bc5..e8aa3ad6db23 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Jan 12 17:06:17 UTC 2016
+# Tue Mar 8 17:28:49 UTC 2016
pkgbase = libopencm3-git
pkgdesc = Open Source firmware library for various ARM Cortex microcontrollers
- pkgver = r1767.ad5ec6a
+ pkgver = r1789.20e1ee1
pkgrel = 1
url = http://www.libopencm3.org/
arch = any
@@ -15,9 +15,9 @@ pkgbase = libopencm3-git
options = staticlibs
options = !buildflags
source = git://github.com/libopencm3/libopencm3.git
- source = remove_install.patch::https://github.com/libopencm3/libopencm3/commit/7c1cd2e5cd3f3d1193ee375b46cfd8afaccb89f7.patch
+ source = 0001-Revert-Drop-install-target-and-documentation.patch
sha256sums = SKIP
- sha256sums = d611a1dedd6b86eed552247bf13ee06343b14adfa863b9edc52039441b18120d
+ sha256sums = 7d96774d48f00d487416b73d3ff6ecc11d9e0048eadc24e721d2830ab8f7b96c
pkgname = libopencm3-git
diff --git a/0001-Revert-Drop-install-target-and-documentation.patch b/0001-Revert-Drop-install-target-and-documentation.patch
new file mode 100644
index 000000000000..416499170371
--- /dev/null
+++ b/0001-Revert-Drop-install-target-and-documentation.patch
@@ -0,0 +1,90 @@
+From e64d123386aabf9884dccabce197855aa7338ddd Mon Sep 17 00:00:00 2001
+From: Anatol Pomozov <anatol.pomozov@gmail.com>
+Date: Tue, 8 Mar 2016 08:45:34 -0800
+Subject: [PATCH] Revert "Drop "install" target and documentation."
+
+This reverts commit 7c1cd2e5cd3f3d1193ee375b46cfd8afaccb89f7.
+---
+ Makefile | 25 ++++++++++++++++++++++++-
+ README.md | 11 ++++++++---
+ 2 files changed, 32 insertions(+), 4 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index d93efea..8476bd1 100644
+--- a/Makefile
++++ b/Makefile
+@@ -23,6 +23,13 @@ PREFIX ?= arm-none-eabi
+ STYLECHECK := scripts/checkpatch.pl
+ STYLECHECKFLAGS := --no-tree -f --terse --mailback
+
++DESTDIR ?= /usr/local
++
++INCDIR := $(DESTDIR)/$(PREFIX)/include
++LIBDIR := $(DESTDIR)/$(PREFIX)/lib
++SHAREDIR := $(DESTDIR)/$(PREFIX)/share/libopencm3/scripts
++INSTALL := install
++
+ space:=
+ space+=
+ SRCLIBDIR:= $(subst $(space),\$(space),$(realpath lib))
+@@ -64,6 +71,22 @@ $(LIB_DIRS): $(IRQ_DEFN_FILES:=.genhdr)
+ lib: $(LIB_DIRS)
+ $(Q)true
+
++install: lib
++ @printf " INSTALL headers\n"
++ $(Q)$(INSTALL) -d $(INCDIR)/libopencm3
++ $(Q)$(INSTALL) -d $(INCDIR)/libopencmsis
++ $(Q)$(INSTALL) -d $(LIBDIR)
++ $(Q)$(INSTALL) -d $(SHAREDIR)
++ $(Q)cp -r include/libopencm3/* $(INCDIR)/libopencm3
++ $(Q)cp -r include/libopencmsis/* $(INCDIR)/libopencmsis
++ @printf " INSTALL libs\n"
++ $(Q)$(INSTALL) -m 0644 lib/*.a $(LIBDIR)
++ @printf " INSTALL ldscripts\n"
++ $(Q)$(INSTALL) -m 0644 lib/*.ld $(LIBDIR)
++ $(Q)$(INSTALL) -m 0644 lib/efm32/*/*.ld $(LIBDIR)
++ @printf " INSTALL scripts\n"
++
++
+ html doc:
+ $(Q)$(MAKE) -C doc html
+
+@@ -106,4 +129,4 @@ genlinktests: $(LDTESTS:.data=.ldtest)
+ fi;
+
+
+-.PHONY: build lib $(LIB_DIRS) doc clean generatedheaders cleanheaders stylecheck genlinktests
++.PHONY: build lib $(LIB_DIRS) install doc clean generatedheaders cleanheaders stylecheck genlinktests
+diff --git a/README.md b/README.md
+index 938d5e2..ff331aa 100644
+--- a/README.md
++++ b/README.md
+@@ -136,9 +136,13 @@ https://github.com/libopencm3/libopencm3-examples
+ Installation
+ ------------
+
+-Simply pass -I and -L flags to your own project. See the libopencm3-examples
+-repository for an example of using this library as a git submodule, the most
+-popular method of use.
++ $ make install
++
++This will install the library into `/usr/local`. (permissions permitting)
++
++If you want to install it elsewhere, use the following syntax:
++
++ $ make DESTDIR=/opt/libopencm3 install
+
+ It is strongly advised that you do not attempt to install this library to any
+ path inside your toolchain itself. While this means you don't have to include
+@@ -147,6 +151,7 @@ linker from picking the right versions of libraries. Common symptoms are
+ hardfaults caused by branches into arm code. You can use `arm-none-eabi-objdump`
+ to check for this in your final elf. You have been warned.
+
++
+ Coding style and development guidelines
+ ---------------------------------------
+
+--
+2.7.2
+
diff --git a/PKGBUILD b/PKGBUILD
index bc906cc61972..3fba7f68b91a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Martin Schmölzer <mschmoelzer@gmail.com>
pkgname=libopencm3-git
-pkgver=r1767.ad5ec6a
+pkgver=r1789.20e1ee1
pkgrel=1
pkgdesc='Open Source firmware library for various ARM Cortex microcontrollers'
arch=(any)
@@ -10,9 +10,9 @@ license=(GPL)
makedepends=(git arm-none-eabi-gcc arm-none-eabi-newlib python-yaml)
options=(!strip staticlibs !buildflags)
source=(git://github.com/libopencm3/libopencm3.git
- remove_install.patch::https://github.com/libopencm3/libopencm3/commit/7c1cd2e5cd3f3d1193ee375b46cfd8afaccb89f7.patch)
+ 0001-Revert-Drop-install-target-and-documentation.patch)
sha256sums=('SKIP'
- 'd611a1dedd6b86eed552247bf13ee06343b14adfa863b9edc52039441b18120d')
+ '7d96774d48f00d487416b73d3ff6ecc11d9e0048eadc24e721d2830ab8f7b96c')
pkgver() {
cd libopencm3
@@ -21,7 +21,7 @@ pkgver() {
prepare() {
cd libopencm3
- patch -p1 -R < ../remove_install.patch
+ patch -p1 < ../0001-Revert-Drop-install-target-and-documentation.patch
}
build() {