summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..32d7e2c82cf4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = libopencm3-git
+ pkgdesc = Open Source firmware library for various ARM Cortex microcontrollers
+ pkgver = r1638.3a106db
+ pkgrel = 1
+ url = http://www.libopencm3.org/
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = arm-none-eabi-gcc
+ makedepends = arm-none-eabi-newlib
+ makedepends = python-yaml
+ options = !strip
+ options = staticlibs
+ source = git://github.com/libopencm3/libopencm3.git
+ sha256sums = SKIP
+
+pkgname = libopencm3-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4191a2386198
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Martin Schmölzer <mschmoelzer@gmail.com>
+
+pkgname=libopencm3-git
+pkgver=r1638.3a106db
+pkgrel=1
+pkgdesc='Open Source firmware library for various ARM Cortex microcontrollers'
+arch=(any)
+url='http://www.libopencm3.org/'
+license=(GPL)
+makedepends=(git arm-none-eabi-gcc arm-none-eabi-newlib python-yaml)
+options=(!strip staticlibs)
+source=(git://github.com/libopencm3/libopencm3.git)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd libopencm3
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd libopencm3
+ make lib
+}
+
+package() {
+ cd libopencm3
+ make DESTDIR="$pkgdir" PREFIX=/usr/arm-none-eabi install
+}