summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD31
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9cf494a1bc60
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = libopenrct2
+ pkgdesc = Base library for OpenRCT2
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://openrct2.website
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ arch = aarch64
+ license = GPL3
+ makedepends = cmake
+ depends = curl
+ depends = jansson
+ depends = fontconfig
+ depends = libpng
+ depends = openssl
+ depends = libzip
+ source = https://github.com/OpenRCT2/OpenRCT2/archive/v0.1.0.tar.gz
+ sha256sums = 0347a47d380fc18ea543928c92a13d1bdb4431573154afeb80fa33f1149e6992
+
+pkgname = libopenrct2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..27c290727901
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Ted John <intelorca@gmail.com>
+pkgname=libopenrct2
+pkgver=0.1.0
+pkgrel=1
+pkgdesc='Base library for OpenRCT2'
+arch=('i686' 'x86_64' 'armv7h' 'aarch64')
+url='https://openrct2.website'
+license=('GPL3')
+depends=('curl' 'jansson' 'fontconfig' 'libpng' 'openssl' 'libzip')
+makedepends=('cmake')
+source=("https://github.com/OpenRCT2/OpenRCT2/archive/v$pkgver.tar.gz")
+sha256sums=('0347a47d380fc18ea543928c92a13d1bdb4431573154afeb80fa33f1149e6992')
+
+build() {
+ cd "$srcdir/OpenRCT2-$pkgver"
+
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo -DCMAKE_INSTALL_PREFIX=/usr ..
+ make libopenrct2
+}
+
+package() {
+ cd "$srcdir/OpenRCT2-$pkgver/build"
+
+ make DESTDIR="$pkgdir" install
+ cd "$pkgdir/usr"
+
+ # Currently the install target builds openrct2 which we don't want
+ rm -rf bin share/applications share/icons share/man share/openrct2/shaders share/openrct2/title
+}