summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
2 files changed, 14 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d580e06a5238..11a3560a0bda 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,23 @@
pkgbase = libosmium-git
pkgdesc = Fast and flexible C++ library for working with OpenStreetMap data.
- pkgver = 2.15.3.r3.g49f8c54c
+ pkgver = 2.16.0.r13.g36c4cc2d
pkgrel = 1
url = http://osmcode.org/libosmium/
arch = x86_64
arch = i686
license = custom
+ makedepends = git
+ makedepends = cmake
+ makedepends = protozero
depends = expat
depends = zlib
depends = bzip2
- depends = boost-libs
+ depends = boost
optdepends = sparsehash: sparse-mem-table index map
optdepends = gdal: convert OSM geometries into OGR geometries
optdepends = geos: convert OSM geometries into GEOS geometries
optdepends = proj: project OSM coordinates into spatial reference systems
+ optdepends = lz4: use LZ4 compression in PBF files
optdepends = doxygen: build Libosmium API documentation
provides = libosmium
conflicts = libosmium
diff --git a/PKGBUILD b/PKGBUILD
index 81c7352023de..e074fc61e6bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,18 @@
# Maintainer: gileri <twiked at gmail d(0)t com>
pkgname=libosmium-git
-pkgver=2.15.3.r3.g49f8c54c
+pkgver=2.16.0.r13.g36c4cc2d
pkgrel=1
pkgdesc="Fast and flexible C++ library for working with OpenStreetMap data."
url="http://osmcode.org/libosmium/"
arch=('x86_64' 'i686')
license=('custom')
-depends=('expat' 'zlib' 'bzip2' 'boost-libs')
+depends=('expat' 'zlib' 'bzip2' 'boost')
+makedepends=('git' 'cmake' 'protozero')
optdepends=('sparsehash: sparse-mem-table index map'
'gdal: convert OSM geometries into OGR geometries'
'geos: convert OSM geometries into GEOS geometries'
'proj: project OSM coordinates into spatial reference systems'
+ 'lz4: use LZ4 compression in PBF files'
'doxygen: build Libosmium API documentation')
conflicts=('libosmium')
provides=('libosmium')
@@ -26,12 +28,10 @@ build() {
mkdir "${srcdir}"/libosmium/build
cd libosmium/build
cmake \
- -DINSTALL_GDALCPP=ON \
- -DINSTALL_PROTOZERO=ON \
- -DINSTALL_UTFCPP=ON \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX:PATH=/usr \
- ..
+ -DINSTALL_GDALCPP=ON \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX:PATH=/usr \
+ ..
make
}