summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD36
-rw-r--r--libpedsim.CMakeLists12
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fd72681023c8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = libpedsim
+ pkgdesc = A Microscopic Pedestrian Crowd Simulation System
+ pkgver = 2.3
+ pkgrel = 2
+ url = http://pedsim.silmaril.org/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake>=2.8
+ depends = gcc-libs
+ source = http://pedsim.silmaril.org/dist/libpedsim/20140211-libpedsim-2-3-src.tar.gz
+ source = libpedsim.CMakeLists
+ md5sums = 6c33004b0a3c7e5270347f9515ba33a3
+ md5sums = 264590a8e55e2f7e10885cf33935b740
+
+pkgname = libpedsim
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f212d1d41f2a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Thomas Laroche <tho.laroche@gmail.com>
+pkgname=libpedsim
+pkgver=2.3
+pkgrel=2
+pkgdesc="A Microscopic Pedestrian Crowd Simulation System"
+arch=('i686' 'x86_64')
+url="http://pedsim.silmaril.org/"
+license=('GPL3')
+depends=('gcc-libs')
+makedepends=('cmake>=2.8')
+source=("http://pedsim.silmaril.org/dist/libpedsim/20140211-$pkgname-2-3-src.tar.gz"
+ libpedsim.CMakeLists)
+md5sums=('6c33004b0a3c7e5270347f9515ba33a3'
+ '264590a8e55e2f7e10885cf33935b740')
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ cp "$srcdir/libpedsim.CMakeLists" CMakeLists.txt
+ sed -i "s/ped_includes.h/pedsim.h/" examples/example.cpp
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir/" install
+}
diff --git a/libpedsim.CMakeLists b/libpedsim.CMakeLists
new file mode 100644
index 000000000000..917ff7765e46
--- /dev/null
+++ b/libpedsim.CMakeLists
@@ -0,0 +1,12 @@
+cmake_minimum_required(VERSION 2.8)
+
+project (libpedsim)
+set(CMAKE_BUILD_TYPE Release)
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++0x")
+
+#include_directories(${CMAKE_CURRENT_SOURCE_DIR}/include)
+add_library(pedsim SHARED ped_obstacle.cpp ped_vector.cpp ped_waypoint.cpp ped_agent.cpp ped_scene.cpp ped_tree.cpp)
+install(TARGETS pedsim DESTINATION lib)
+install(FILES ped_includes.h DESTINATION include RENAME pedsim.h)
+install(FILES ped_agent.h ped_obstacle.h ped_scene.h ped_tree.h ped_vector.h ped_waypoint.h DESTINATION include)
+install(FILES examples/example.cpp DESTINATION share/doc/libpedsim)