summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD59
3 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c6e36f611d83
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Tue Sep 1 09:45:29 UTC 2020
+pkgbase = libpng-apng
+ pkgdesc = A collection of routines used to create PNG format graphics files
+ pkgver = 1.6.37
+ pkgrel = 1
+ url = http://www.libpng.org/pub/png/libpng.html
+ arch = x86_64
+ license = custom
+ depends = zlib
+ depends = sh
+ provides = libpng=1.6.37
+ conflicts = libpng
+ replaces = libpng
+ source = https://downloads.sourceforge.net/sourceforge/libpng/libpng-1.6.37.tar.xz
+ source = https://downloads.sourceforge.net/sourceforge/libpng-apng/libpng-1.6.37-apng.patch.gz
+ sha256sums = 505e70834d35383537b6491e7ae8641f1a4bed1876dbfe361201fc80868d88ca
+ sha256sums = 823bb2d1f09dc7dae4f91ff56d6c22b4b533e912cbd6c64e8762255e411100b6
+
+pkgname = libpng-apng
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c3acd559a791
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+libpng-*-apng.patch.gz
+libpng-*.tar.xz
+libpng-apng-*.log
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..833492c91b5a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: Yardena Cohen <yardenack@gmail.com>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+# Contributor: dorphell <dorphell@archlinux.org>
+# Contributor: Travis Willard <travis@archlinux.org>
+# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
+
+libname=libpng
+pkgname=$libname-apng
+pkgver=1.6.37
+_apngver=1.6.37
+pkgrel=1
+pkgdesc="A collection of routines used to create PNG format graphics files"
+arch=('x86_64')
+url="http://www.libpng.org/pub/png/libpng.html"
+license=('custom')
+depends=('zlib' 'sh')
+provides=(libpng=$pkgver)
+replaces=(libpng)
+conflicts=(libpng)
+validpgpkeys=('8048643BA2C840F4F92A195FF54984BFA16C640F') # Glenn Randers-Pehrson (mozilla) <glennrp@gmail.com>
+source=("https://downloads.sourceforge.net/sourceforge/$libname/$libname-$pkgver.tar.xz"
+ "https://downloads.sourceforge.net/sourceforge/libpng-apng/libpng-$_apngver-apng.patch.gz")
+sha256sums=('505e70834d35383537b6491e7ae8641f1a4bed1876dbfe361201fc80868d88ca'
+ '823bb2d1f09dc7dae4f91ff56d6c22b4b533e912cbd6c64e8762255e411100b6')
+
+prepare() {
+ cd $libname-$pkgver
+
+ # Add animated PNG (apng) support. Required by Firefox
+ # see http://sourceforge.net/projects/libpng-apng/
+ gzip -cd ../libpng-$_apngver-apng.patch.gz | patch -Np1
+}
+
+build() {
+ cd $libname-$pkgver
+
+ ./configure \
+ --prefix=/usr \
+ --disable-static
+ make
+}
+
+check() {
+ cd $libname-$pkgver
+
+ make check
+}
+
+package() {
+ cd $libname-$pkgver
+
+ make DESTDIR="$pkgdir" install
+
+ install -D -m0644 LICENSE "$pkgdir/usr/share/licenses/$libname/LICENSE"
+
+ cd contrib/pngminus
+ make PNGLIB_SHARED="-L$pkgdir/usr/lib -lpng" CFLAGS="$CFLAGS" LDFLAGS="$LDFLAGS" png2pnm pnm2png
+ install -m0755 png2pnm pnm2png "$pkgdir/usr/bin/"
+}